lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Svensson <si...@devhost.se>
Subject Re: Update on dev happenings
Date Fri, 08 Feb 2019 07:00:47 GMT
Hi,

The main build has a green checkbox and the word "Success" next to it. I
would classify this as slightly inaccurate, the build totally failed.
The build script logged an error, but exited with a exit code of 0 so no
error was signaled.

In short, "dotnet.exe restore" failed for unknown reasons, and this
continues in all builds since 1190. There are silent failures before the
restore; where the build scripts should output some information about
build numbers, directory paths and such, it should also output
"dotnet.exe --version" and "dotnet.exe --info". These worked in build
1189, but failed in 1190.

A perhaps related observation is that we, starting with build 1190, also
need to install .NET SDK 2.0.0 every run. It could be relevant that it's
over 6 months between build 1189 and 1190, so there could perhaps be a
change in TeamCity we need to track down.

Is there an administrative ui in TeamCity that I can get access to? I
believe the next step would be to debug (read: qualified guessing) the
build script on a separate branch; would this be picked up automatically
by TeamCity?

// Simon Svensson

On 2019-02-06 13:57, Laimonas Simutis wrote:
> Simon,
> 
> I was able to get the base builds going but as you already noticed, the
> subsequent builds are failing outright. The build structure has changed
> quite a bit since the last time I as in there, so it's taking me some time
> to understand what's going on. I will continue to try to untangle it or set
> up a new build flow in there if that fails.
> 
> Chris, here is the project link:
> https://teamcity.jetbrains.com/project.html?projectId=LuceneNet&tab=projectOverview
> if you want to take a look, perhaps you will see right away what's up.
> 
> Laimonas
> 
> 
> On Wed, Feb 6, 2019 at 12:46 AM Chris Moschini <chris@brass9.com> wrote:
> 
>> We use Lucene.Net to do conventional search at:
>>
>> https://conservationx.com
>>
>> Analyzer, Indexer, Highlighter, Tokenizer, FuzzySearch, Levenshtein, etc
>>
>> There was a problem mentioned about TeamCity; is there a way I can learn
>> more in case I'd possibly be able to get it working? Where is it checked
>> in, where is it running, etc
>>
> 

Mime
View raw message