lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shad Storhaug (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (LUCENENET-593) NullReferenceException in Linux
Date Thu, 19 Oct 2017 16:15:00 GMT

     [ https://issues.apache.org/jira/browse/LUCENENET-593?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shad Storhaug resolved LUCENENET-593.
-------------------------------------
       Resolution: Fixed
         Assignee: Shad Storhaug
    Fix Version/s: Lucene.Net 4.8.0

Resolved with these commits:
* https://github.com/apache/lucenenet/commit/c14c27e7696cf88d628dae83b5190d8c87e9fac8
* https://github.com/apache/lucenenet/commit/f486e5c421f2be952ff6805b8b0dfa457513e5a1

> NullReferenceException in Linux
> -------------------------------
>
>                 Key: LUCENENET-593
>                 URL: https://issues.apache.org/jira/browse/LUCENENET-593
>             Project: Lucene.Net
>          Issue Type: Bug
>          Components: Lucene.Net Core
>    Affects Versions: Lucene.Net 4.8.0, Lucene.Net 5.0 PCL
>         Environment: Linux (ubuntu 64 bit, maybe all linux variants)
>            Reporter: Warren Falk
>            Assignee: Shad Storhaug
>             Fix For: Lucene.Net 4.8.0
>
>
> A NullReferenceException on any attempt to query in Linux (ubuntu x64 in my tests)
> I was able to track this down to the following line in Constants.cs
>         {{public static readonly string OS_ARCH = GetEnvironmentVariable("PROCESSOR_ARCHITECTURE",
"x86");}}
> Sure enough, PROCESSOR_ARCHITECTURE is not set by default in ubuntu server x64 and when
I set it, there is no failure.
> I would fix this, but I'm not sure what this value is used for, so I am not sure what
the appropriate behavior should be.  Should we try to find the correct architecture here?
 And what is the correct string, "amd64", "x64", "x86_64"?  Or do we really just want to know
the value of that if it is actually not set, should we leave it blank?  The issue is that
the InfoWriter can't write a null, but it could write an empty string.
> I'll submit a pull request if anyone can tell me what correct behavior should be.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message