lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Svensson <si...@devhost.se>
Subject Re: [Vote] Apache Lucene.Net 4.8.0-beta00001
Date Sat, 06 May 2017 21:57:23 GMT
On 2017-05-06 02:15, Shad Storhaug wrote:
> So, after 4 1/2 years of silence, we are ready to shake up the world with a new version
of Lucene.Net. 
> 
> 
> The source and binary packages are available for inspection at: https://dist.apache.org/repos/dist/dev/lucenenet/.
> 
> There is a MyGet feed that can be accessed at:
> V2: https://www.myget.org/F/lucene-net-nuget/api/v2 (VS2012+)
> V3: https://www.myget.org/F/lucene-net-nuget/api/v3/index.json (VS2015+)
> 
> The tag is: https://github.com/apache/lucenenet/releases/tag/Lucene.Net_4_8_0_beta00001
> 
> 
> Please review the beta and vote.
> This vote will close no sooner than 72 hours from now,
> i.e. sometime after 00:00 UTC 9-May 2017
> 
> +1 - lets rock
> 0 - indifferent
> -1 - Not ready, because...
> 
> 
> Thanks,
> Shad Storhaug (NightOwl888)

Hi,

I'm building and running the tests on my machine, and I am getting
errors after running for 45 minutes with "Couldn't find a project to run
test from. Ensure a project exists in [root]\build". Several test
projects has completed before this happens.

I am on git commit db82646ee1c88c1b0b8ca6a18ea1411da7019be9 and running
".\build.bat -t". Running without -t builds everything successfully.
(Technically it doesn't fail, but I havn't verified the output.)

I'm on Windows 10 Creators Update and .NET Framework 4.7.02046.

There is a high probability that I'm missing a required framework/sdk. I
am not sure I have everything needed to run the tests; but if so it
isn't obvious to me what I am missing.

Anything obvious I've missed?

// Simon

--- Console output below:

Framework: netcoreapp1.0
Directory: C:\dev\lucenenet\src\Lucene.Net.Tests


    Directory: C:\dev\lucenenet\release\TestResults\netcoreapp1.0


Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----       2017-05-06     22:45                Lucene.Net.Tests
dotnet.exe test 'C:\dev\lucenenet\src\Lucene.Net.Tests\project.json'
--configuration Release --framework netcoreapp1.0 --no-build
--result:C:\dev\lucenenet\release\TestResults\netcoreapp1.0\Lucene.Net.Tests\TestResult.xml
--teamcity

Welcome to .NET Core!
---------------------
Learn more about .NET Core @ https://aka.ms/dotnet-docs. Use dotnet
--help to see available commands or go to https://aka.ms/dotnet-cli-docs.

Telemetry
--------------
The .NET Core tools collect usage data in order to improve your
experience. The data is anonymous and does not include command-line
arguments. The data is collected by Microsoft and shared with the community.
You can opt out of telemetry by setting a DOTNET_CLI_TELEMETRY_OPTOUT
environment variable to 1 using your favorite shell.
You can read more about .NET Core tools telemetry @
https://aka.ms/dotnet-cli-telemetry.

Configuring...
-------------------
A command is running to initially populate your local package cache, to
improve restore speed and enable offline access. This command will take
up to a minute to complete and will only happen once.
Decompressing 100% 6381 ms
Expanding 100% 13305 ms
Couldn't find a project to run test from. Ensure a project exists in
C:\dev\lucenenet\build.
Or pass the path to the project
Directory: C:\dev\lucenenet\src\Lucene.Net.Tests.Analysis.Common
d-----       2017-05-06     22:46
Lucene.Net.Tests.Analysis.Common
dotnet.exe test
'C:\dev\lucenenet\src\Lucene.Net.Tests.Analysis.Common\project.json'
--configuration Release --framework netcoreapp1.0 --no-build
--result:C:\dev\lucenenet\release\TestResults\netcoreapp1.0\Lucene.Net.Tests.Analysis.Common\TestResult.xml
--teamcity
Couldn't find a project to run test from. Ensure a project exists in
C:\dev\lucenenet\build.
Or pass the path to the project

--- snip, above message repeated for several other test project paths.

Mime
View raw message