lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Itamar Syn-Hershko <ita...@code972.com>
Subject Re: Problems when running a search in my production environment
Date Mon, 15 May 2017 15:19:37 GMT
What is the exact exception(s) ?

--

Itamar Syn-Hershko
Freelance Developer & Consultant
Elasticsearch Partner
Microsoft MVP | Lucene.NET PMC
http://code972.com | @synhershko <https://twitter.com/synhershko>
http://BigDataBoutique.co.il/

On Mon, May 15, 2017 at 6:02 PM, Matthias Strauss - xRM1 Business Solutions
<Matthias.Strauss@xrm1.com> wrote:

> Hey guys,
>
> I'm not sure if this is a thing for the user or dev mailing list, but I've
> got a problem running a basic search in my production environment (CRM).
>
>
> 1.       When adding a simple document to my IndexWriter I will get a
> runtime error in the following location:
> Lucene.Net\Util\AttributeSource.cs
> internal static Type GetClassForInterface<T>() where T : IAttribute
> It crashes at: "attClass.GetTypeInfo()"
>
> So I think this method is a feature of mscorlib.dll, but why is it
> crashing on my server and not on my local machine?
>
>
> 2.       When running the code in sandbox mode (partially trusted code) my
> sample app crashes even earlier when initializing the IndexWriter (with
> RamDirectory) at:
> Lucene.Net\Index\LiveIndexWriterConfig.cs
>                                 internal LiveIndexWriterConfig(Analyzer
> analyzer, LuceneVersion matchVersion)
> Exception: "Unable to load one or more of the requested types. Retrieve
> the LoaderExceptions property for more information." at source "mscorlib".
>
> Locally the code is working fine.
> I'm merging my code with ILMerge. Could this be the cause of the problem?
> When I merge the 4 basic Lucene.Net dll's into a single one, it's still
> working fine locally.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message