lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SuperCiccio <sc_030...@yahoo.it.INVALID>
Subject Re: Framework 4.5
Date Thu, 18 May 2017 13:03:03 GMT
Indeed, I've already built following projects with VS 2015 referencing 
4.5 Framework, because I use only theese:

- Lucene.Net
- Lucene.Net.Analysis.Common
- Lucene.Net.Queries
- Lucene.Net.QueryParser
- Lucene.Net.Sandbox

I would like to know wether any contraindications exist in what I made. 
However I'll let them run and see what happens.
Anyway, when possible (an when the format you tell about is stabilized), 
I'll try to build entire solution in 4.5 and run tests.

Thank you


> Alright. I don't have an issue with supporting 4.5 (since we are basically just supporting
the API compatibility for 4.5 the same way .NET Standard 1.0 does). But we are short-handed
and ask that if you need this that you please help out.
>
> If you could try compiling on 4.5 and let us know if there are any issues to be aware
of, that would be great. Or, better yet submit a PR with the changes. Note that there is a
.csproj file, a project.json file, and a PROJECTNAME.project.json file for each project that
all need to be updated, plus the build script in the build directory. I am fairly certain
all of the dependencies support 4.5 or lower. Also, I just updated some of those files, so
be sure you pull the latest before getting started.
>
> And of course, in addition to just getting it to compile, all tests need to pass on 4.5.
I doubt such a small change will cause any problems, but you never know.
>
> Do note that we will likely be making the switch to the new .csproj format soon, so if
you can wait, it might be better to do it after that change.
>
> Thanks,
> Shad Storhaug (NightOwl888)
>
> -----Original Message-----
> From: SuperCiccio [mailto:sc_030268@yahoo.it.INVALID]
> Sent: Thursday, May 18, 2017 4:06 PM
> To: dev@lucenenet.apache.org
> Subject: Re: Framework 4.5
>
> Yes, I'm perfectly aware of this.
> My question is only about build time: I need to mantain the 4.5 build environment for
now.
> So, the software wil be built in 4.5 but will probably (surely) meet
> 4.5.2 and subsequent in the runtime environment.
>
> Thank you
>
>> This was in development for a while.. We should probably use 4.5.2
>> indeed
>>
>> --
>>
>> Itamar Syn-Hershko
>> Freelance Developer & Consultant
>> Elasticsearch Partner
>> Microsoft MVP | Lucene.NET PMC
>> http://code972.com | @synhershko <https://twitter.com/synhershko>
>> http://BigDataBoutique.co.il/
>>
>> On Wed, May 17, 2017 at 9:13 PM, Shad Storhaug <shad@shadstorhaug.com>
>> wrote:
>>
>>> I wasn't involved in the project when that decision was made.
>>> However, do note that Microsoft no longer supports .NET Framework
>>> versions lower than
>>> 4.5.2 (except for 3.5): https://blogs.msdn.microsoft.
>>> com/dotnet/2015/12/09/support-ending-for-the-net-framework-
>>> 4-4-5-and-4-5-1/
>>>
>>> If we were to change from 4.5.1, it would make more sense to upgrade
>>> to
>>> 4.5.2 than to downgrade to 4.5 so at least we are on a supported
>>> framework version. But since everything above 4.5 is an in-place
>>> upgrade it probably doesn't matter too much.
>>>
>>> That said, you might be able to build the project on 4.5. I am not
>>> sure if there are any API calls or dependencies that are preventing a
>>> downgrade from taking place - the only way to know for sure is to try it.
>>>
>>> @Itamar - do you know why 4.5.1 was chosen?
>>>
>>> Thanks,
>>> Shad Storhaug (NightOwl888)
>>>
>>> -----Original Message-----
>>> From: SuperCiccio [mailto:sc_030268@yahoo.it.INVALID]
>>> Sent: Wednesday, May 17, 2017 9:44 PM
>>> To: dev@lucenenet.apache.org
>>> Subject: Framework 4.5
>>>
>>> Can I build Lucene.Net 4.8 against .NET Framework 4.5 instead of 4.5.1?
>>> Why is 4.5.1 version required?
>>>
>>> Thanks

Mime
View raw message