lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shad Storhaug <s...@shadstorhaug.com>
Subject RE: Framework 4.5
Date Wed, 17 May 2017 18:13:45 GMT
I wasn't involved in the project when that decision was made. However, do note that Microsoft
no longer supports .NET Framework versions lower than 4.5.2 (except for 3.5): https://blogs.msdn.microsoft.com/dotnet/2015/12/09/support-ending-for-the-net-framework-4-4-5-and-4-5-1/

If we were to change from 4.5.1, it would make more sense to upgrade to 4.5.2 than to downgrade
to 4.5 so at least we are on a supported framework version. But since everything above 4.5
is an in-place upgrade it probably doesn't matter too much.

That said, you might be able to build the project on 4.5. I am not sure if there are any API
calls or dependencies that are preventing a downgrade from taking place - the only way to
know for sure is to try it.

@Itamar - do you know why 4.5.1 was chosen?

Thanks,
Shad Storhaug (NightOwl888)

-----Original Message-----
From: SuperCiccio [mailto:sc_030268@yahoo.it.INVALID] 
Sent: Wednesday, May 17, 2017 9:44 PM
To: dev@lucenenet.apache.org
Subject: Framework 4.5

Can I build Lucene.Net 4.8 against .NET Framework 4.5 instead of 4.5.1? 
Why is 4.5.1 version required?

Thanks

Mime
View raw message