lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conniey <...@git.apache.org>
Subject [GitHub] lucenenet issue #191: Migrating Lucene.Net to .NET Core
Date Thu, 24 Nov 2016 01:09:26 GMT
Github user conniey commented on the issue:

    https://github.com/apache/lucenenet/pull/191
  
    @NightOwl888 
    
    > Connie, do you think it is possible to utilize VS 2015 for development on both .NET
frameworks?
    
    Yes, the .NET Core projects already build for both frameworks, so I was hoping that the
old csprojs and old solution could be removed/replaced in the future.  Then all development
could be done using Visual Studio 2015.  You can switch between developing for different frameworks
using the Navigation Bar in VS2015.
    
    ![image](https://cloud.githubusercontent.com/assets/10136526/20583469/fe31522c-b19e-11e6-8846-e49e7298693d.png)
    
    > Secondly, I am getting some errors when building Lucene.Net.Portable.sln using Visual
Studio 2015 Community. Here is a screenshot. The issue appears to stem from line 262 in C:\Program
Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\DotNet\Microsoft.DotNet.Common.Targets on
my machine.
    
    Urgh. I used to get that error. I worked around it by running `dotnet restore` on the
directory first before opening Lucene.Net.Portable.sln in Visual Studio.  Would you mind sending
me the `.vs\restore.dg` file when you get that error?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message