lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NightOwl888 <...@git.apache.org>
Subject [GitHub] lucenenet issue #191: Migrating Lucene.Net to .NET Core
Date Wed, 23 Nov 2016 01:55:04 GMT
Github user NightOwl888 commented on the issue:

    https://github.com/apache/lucenenet/pull/191
  
    Thanks Connie. I am having my first stab at working with this branch, but I am having
a few problems getting set up.
    
    First of all, I don't have a copy of Visual Studio 2013 developer. I have a copy of Visual
Studio 2013 Web Developer, but I never use it because I cannot install the useful test runner
and Git extensions. I tried it, but there is a lot of friction without these tools.
    
    I gave my VS 2012 Professional a shot, but there doesn't appear to be a test runner for
NUnit 3.5 in this environment. I am down to running the tests on the command line for lack
of alternatives. As such, this is going to be a roadblock for me to maintain this project
effectively. Any chance you can talk to someone @ Microsoft to see if you can get me an honorary
copy of Visual Studio 2013 Developer? Or, disregard if the plan is to get us onto VS 2015
Community exclusively before this branch is merged.
    
    Secondly, I am getting some errors when building Lucene.Net.Portable.sln using Visual
Studio 2015 Community. Here is a screenshot. The issue appears to stem from line 262 in `C:\Program
Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\DotNet\Microsoft.DotNet.Common.Targets` on
my machine.
    
    ![image](https://cloud.githubusercontent.com/assets/1538288/20548777/fbe5abbc-b158-11e6-838b-422b2e0d5378.png)
    
    I have both VS2015 update 3 and the .NET Core 1.0.1 SDK installed. Perhaps there is another
prerequisite that was missed?



---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message