lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Herndon <mhern...@wickedsoftware.net>
Subject Re: [Lucene.Net] Could not load assembly
Date Sat, 11 Jun 2011 23:15:55 GMT
In the past people have used project linker.  However there is something
newer that could be use which is the portable class library:
http://msdn.microsoft.com/en-us/library/gg597391.aspx

Either way, unless someone knows an easier way (possibly changing the
project guids),  you'll have to use a separate project files to compile them
against the silverlight framework.

And that is even if the Lucene.Net core is currently compatible with the WP7
apis. If it is not, that could be small project worth of changes within
itself. (someone might have tried to compile it before hand).

- Michael

On Sat, Jun 11, 2011 at 6:58 PM, Prescott Nasser <geobmx540@hotmail.com>wrote:

>
> Hmm, that's likely it. Do you know a fast way to compile Lucene.Net and the
> IsolatedStorage to the silverlight framework? I could create new wp7 class
> projects and import all the files, but surely there is another way?
>
>
>
>
> ----------------------------------------
> > Date: Sat, 11 Jun 2011 18:34:02 -0400
> > From: mherndon@wickedsoftware.net
> > To: lucene-net-dev@lucene.apache.org
> > Subject: Re: [Lucene.Net] Could not load assembly
> >
> > was it compiled against the wp7 version of silverlight? or .net full
> > framework?
> >
> > On Sat, Jun 11, 2011 at 6:28 PM, Prescott Nasser wrote:
> >
> > >
> > > I have - I wasn't sure how to fake IsolatedStorage and figured I'd just
> try
> > > and get it running in a wp7 app with the emulator, then go back and
> start
> > > filling in holes (like the test proj)
> > >
> > >
> > >
> > >
> > > ----------------------------------------
> > > > From: digydigy@gmail.com
> > > > To: lucene-net-dev@lucene.apache.org
> > > > Date: Sun, 12 Jun 2011 01:23:35 +0300
> > > > Subject: RE: [Lucene.Net] Could not load assembly
> > > >
> > > > Hard to guess.
> > > >
> > > > Have you seen Contrib.IsolatedStorage.Test.csproj?
> > > >
> > > > DIGY
> > > >
> > > > -----Original Message-----
> > > > From: Prescott Nasser [mailto:geobmx540@hotmail.com]
> > > > Sent: Sunday, June 12, 2011 12:33 AM
> > > > To: lucene-net-dev@lucene.apache.org
> > > > Subject: [Lucene.Net] Could not load assembly
> > > >
> > > >
> > > > While trying to set up a test for Contrib.IsolatedStorage, I'm
> running
> > > into
> > > > an issue I haven't been able to solve.
> > > >
> > > > {System.TypeLoadException: Could not load type
> > > > 'Lucene.Net.Documents.Document' from assembly 'Lucene.Net,
> > > Version=2.9.4.2,
> > > > Culture=neutral, PublicKeyToken=null'.
> > > > at System.Windows.Controls.Primitives.ButtonBase.OnClick()
> > > > at System.Windows.Controls.Button.OnClick()
> > > > at
> > > >
> > >
> System.Windows.Controls.Primitives.ButtonBase.OnMouseLeftButtonUp(MouseButto
> > > > nEventArgs e)
> > > > at System.Windows.Controls.Control.OnMouseLeftButtonUp(Control ctrl,
> > > > EventArgs e)
> > > > at MS.Internal.JoltHelper.FireEvent(IntPtr unmanagedObj, IntPtr
> > > > unmanagedObjArgs, Int32 argsTypeIndex, String eventName)
> > > > }
> > > >
> > > > I'm not sure why I'm getting this. When I call the
> > > IsolatedStorageDirectory
> > > > constructor, that runs fine, but when I try to call something from
> the
> > > > Lucene.Net core I'm running into this error.
> > > >
> > > > Directory isoDir = new IsolatedStorageDirectory("//", null);
> > > > Document doc; //this line throws the error, the above runs fine.
> > > >
> > > > I've cleared the GAC, made sure I've got the latest binaries
> referenced
> > > etc.
> > > >
> > > > Any thoughts?
> > > >
> > > > Thanks,
> > > > ~Prescott =
> > > >
> > >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message