lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Stewart <Robert_Stew...@epam.com>
Subject [Lucene.Net] index version compatibility (1.9 to 2.9.2)?
Date Thu, 09 Jun 2011 16:33:06 GMT
I have a Lucene index created with Lucene.Net<http://Lucene.Net/> 1.9.  I have a multi-segment
index (non-optimized).   When I run Lucene.Net<http://Lucene.Net/> 2.9.2 on top of that
index, I get IndexOutOfRange exceptions in my collectors.  It is giving me document IDs that
are larger than maxDoc.

My index contains 377831 documents, and IndexReader.MaxDoc() is returning 377831, but I get
documents from Collect() with large values (for instance 379018).  Is an index built with
Lucene.Net<http://Lucene.Net/> 1.9 compatible with 2.9.2?  If not (and I assume it is
not), is there some way I can convert existing indexes? (in production we have many indexes
containing about 200 million docs so I'd much rather convert existing indexes than rebuilt
them).

Thanks
Bob

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message