lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Digy" <digyd...@gmail.com>
Subject RE: [Lucene.Net] Could not load assembly
Date Sat, 11 Jun 2011 22:23:35 GMT
Hard to guess.

Have you seen Contrib.IsolatedStorage.Test.csproj?

DIGY

-----Original Message-----
From: Prescott Nasser [mailto:geobmx540@hotmail.com] 
Sent: Sunday, June 12, 2011 12:33 AM
To: lucene-net-dev@lucene.apache.org
Subject: [Lucene.Net] Could not load assembly


While trying to set up a test for Contrib.IsolatedStorage, I'm running into
an issue I haven't been able to solve.
 
{System.TypeLoadException: Could not load type
'Lucene.Net.Documents.Document' from assembly 'Lucene.Net, Version=2.9.4.2,
Culture=neutral, PublicKeyToken=null'.
   at System.Windows.Controls.Primitives.ButtonBase.OnClick()
   at System.Windows.Controls.Button.OnClick()
   at
System.Windows.Controls.Primitives.ButtonBase.OnMouseLeftButtonUp(MouseButto
nEventArgs e)
   at System.Windows.Controls.Control.OnMouseLeftButtonUp(Control ctrl,
EventArgs e)
   at MS.Internal.JoltHelper.FireEvent(IntPtr unmanagedObj, IntPtr
unmanagedObjArgs, Int32 argsTypeIndex, String eventName)
}
 
I'm not sure why I'm getting this. When I call the IsolatedStorageDirectory
constructor, that runs fine, but when I try to call something from the
Lucene.Net core I'm running into this error.
 
Directory isoDir = new IsolatedStorageDirectory("//", null);
Document doc; //this line throws the error, the above runs fine.
 
I've cleared the GAC, made sure I've got the latest binaries referenced etc.
 
Any thoughts?
 
Thanks,
~Prescott             		 	   		  =


Mime
View raw message