lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhilash ramachandran <abhilash....@gmail.com>
Subject Cannot Escape Special charectors Search with Lucene.Net 2.0
Date Fri, 17 Dec 2010 11:29:03 GMT
Hi,
My Name is Abhilash, working as .Net developer/support.
I have came acroos an issue with search option in our application which uses
Lucene.Net 2.0 version.
The scenario is if I try search a text "Test&&Test" (it is actually
Test&&Test.doc, which is trying to search), it returns 0 hits. While
debugging I could see that the line which wrote to Parse the query is giving
the problem,
Here is the error line code:

Query q=null;

q = new global::Lucene.Net.QueryParsers.QueryParser("content", new
StandardAnalyzer()).Parse(query);
 The variable query at above point contains as this:
(title:(Test&&Test) shorttitle:(Test&&Test) content:(Test&&Test)
keywords:(Test&&Test) description:(Test&&Test) )
and q will get as this:
title:"test test" shorttitle:"test test" content:"test test" keywords:"test
test" description:"test test"

And hence the hit length will be 0 at

IndexSearcher searcher = new IndexSearcher(indexPath);

Hits hits = searcher.Search(q);
I tried adding"\" before &&, tried escape, tried enclosing the text in a ""
but all result the same outcome.
Could anyone please hlep me with any fix to it?
If require I can post the full code here.
Hope to hear from Lucene.Net.
Many thanks
Abhilash

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message