lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "DIGY" <digyd...@gmail.com>
Subject RE: Unit Tests
Date Wed, 19 Sep 2007 05:10:21 GMT
Hi Michael,

Can you try the FieldDocSortedHitQueue.patch in LUCENENET-94?

I think it is a localization problem but don't know the reason yet.

DIGY



-----Original Message-----
From: Michael Garski [mailto:mgarski@mac.com] 
Sent: Wednesday, September 19, 2007 2:44 AM
To: lucene-net-dev@incubator.apache.org
Subject: Re: Unit Tests

Thanks DIGY! 

I also figured out that I had to perform a build on the DemoLib project 
as well to get the tests to pass.  Why are there three separate Visual 
Studio solutions for Lucene.Net rather than having all of the projects 
in one solution with inter-project references?  Is there some compelling 
reason I am not aware of?

I still see two tests that are failing:

Search\TestSort\TestNormalizedScores
Search\TestSort\TestRemoteSort

Both are coming from within the FieldDocSortedHitQueue.LessThan(Object 
a, Object b) method.  Am I the only one seeing this or are these the 
last tests to get to pass for 2.1?  I'm stepping through the tests now 
to determine why they are failing.

Thanks,

Michael


DIGY wrote:
> Compression (Test and Lucene.Net Projects):
> 	1- Add SHARP_ZIP_LIB to Project/Builds/Conditional Compilation
> symbols
> 	2- Add a reference to ICSharpCode.SharpZipLib.dll(which can be found
> with googling) 
>
> Remoting:
> 	Since all tests(TestRemoteSearchable and TestSort) releated with
> remoting use port 1099, it may the case that the port is used by another
> server-thread. Running tests one after another(not alltogether) can be a
> solution.
>
> These are the changes i can remember. 
>
> DIGY
>
>
>
> -----Original Message-----
> From: Michael Garski [mailto:mgarski@mac.com] 
> Sent: Tuesday, September 18, 2007 4:47 AM
> To: lucene-net-dev@incubator.apache.org
> Subject: Unit Tests
>
> I have a question on the unit tests...
>
> I've retrieved the latest source from the svn repository and built both 
> solutions in VS2005, but the unit tests involving remoting or 
> compression fail.
>
> Am I missing a configuration for those to pass?
>
> Thanks,
>
> Michael
>
>   


Mime
View raw message