lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Rodenburg" <jeff.rodenb...@gmail.com>
Subject Re: Error during indexing process
Date Mon, 22 May 2006 21:46:15 GMT
Hi Soormash -

This sounds like a corrupt index.  I've seen this with an index that wasn't
properly closed or an indexing update didn't complete entirely.  Try using
the Luke index interrogation tool (Java app) for evaluating your index and
see if it's still readable.

-- j

On 5/22/06, George Aroush <george@aroush.net> wrote:
>
> Hi Soormash,
>
> I have posted your question to the mailing list.  Please subscribe to the
> list so you can post directly.  See:
> http://incubator.apache.org/projects/lucene.net.html for instructions on
> how
> to subscribe.
>
> Thanks.
>
> -- George Aroush
>
> -----Original Message-----
> From: Soormasher Singh [mailto:soormasher@yahoo.com]
> Sent: Sunday, May 21, 2006 5:01 PM
> To: lucene-net-dev@incubator.apache.org
> Subject: Error during indexing process
>
> Hello there
>
> I'm using Lucene 1.4.3 to index database records (about 100,000 or so).
> Till
> yesterday, everything was going fine and I didn't have any problems in
> indexing.
> Today, out of nowhere, I've started getting the following error:
>
> Cannot rename segments.new to segments
>
> In some cases, it's the same error with the word 'delete' instead of
> rename.
>
>
> Sometimes the above error occurs after indexing 20,000 records, other
> times
> after 2000.
>
> I've tried using StopAnalyzer (which is what I'm using by default) and
> StandardAnalyzer but get the same problem with both.
>
> Any suggestions/workarounds for this. I really need some inputs on this.
>
> Thanks!
>
> soormash
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message