logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ToddA <starman...@gmail.com>
Subject Re: Using VC6 on XP to build log4cxx from latest trunk
Date Mon, 08 Sep 2014 06:55:04 GMT
Hi Thorsten,


> You need to provide all of the errors

I thought I did. I provided a link to the complete compile log, with all 
errors, here: http://pastebin.com/zpKfm7i9

Regarding the problem with XMLPARSEAPI:

> No idea currently, only found the following which suggests you are
> defining the same macro differently for some reason.

I did a search through my build folders apache-ant-1.9.4, apache-log4cxx-
from-svn.140907, apache-maven-3.2.3, apr, apr-util and there is only one file 
that defines XMLPARSEAPI: apr-util\xml\expat\lib\expat.h

If XMLPARSEAPI is being defined differently, it isn't by me that I know of, 
since I'm using expat.h as provided by apr-util. In fact, I have not even 
attempted to add my own code anywhere since I just want to get log4cxx 
compiled.

To see if I could make some progress in getting log4cxx to build, I decided 
to temporarily disable ODBC by editing apr-util\include\apu.hw and setting 
APU_HAVE_ODBC to zero. Here's the complete log: http://pastebin.com/qcHmZX4f

No error 2 anymore but now there are new and different error and warning 
messages. I highlighted them in yellow to make it easy to scroll to them.




Mime
View raw message