logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ervin Bajramovic" ...@aquasant-mt.com>
Subject AW: faild to build log4cxx => undefinde reference to `_imp__apr_xml_parse_file@20'
Date Tue, 09 Jul 2013 09:43:13 GMT
im using mingw with msys

 

Von: Alexandru Zbârcea [mailto:zbarcea.a@gmail.com] 
Gesendet: Dienstag, 9. Juli 2013 11:35
An: Ervin Bajramovic
Cc: log4cxx-user@logging.apache.org
Betreff: Re: faild to build log4cxx => undefinde reference to `_imp__apr_xml_parse_file@20'

 

Hi,

You can't use autotools on WindowsXP just as is. You may use cygwin.

However, I'll try today to use your config. However, you haven't configured things properly.
For example:

On windows, you can't have:

*	PATH: /usr/local/bin

And looking to your output:

	g++ -g -O2 -o trivial.exe trivial.o  -L/usr/local/apr/lib -L/usr/local/lib -lshe

	ll32 -ladvapi32 ../../../src/main/cpp/libs/liblog4cxx.a /usr/local/apr/lib/liba

	prutil-1.a /usr/local/lib/libexpat.dll.a /usr/local/apr/lib/libapr-1.a -lws2_32

	-lrpcrt4 -lmswsock -L/usr/local/lib -L/usr/local/lib


It seems you are using linux paths.

Be right back with more info on it.

On Mon, Jul 8, 2013 at 5:42 PM, Ervin Bajramovic <eb@aquasant-mt.com> wrote:

Hi 

 

I use a virtual windows xp Version 5.1 with sp3 (on a windows 7 pc).

No i dont have autotools installed at my mingw, should i install it?

i also build the following libraries befor:

 

expat-2.1.0

cppunit-1.12.1 

apr-1.4.8

apr-util-1.5.2

 

attached you will find mi config log.

 

Regards Ervin

 

 

 

Von: Alexandru Zbârcea [mailto:zbarcea.a@gmail.com] 
Gesendet: Montag, 8. Juli 2013 15:16
An: Log4CXX User
Betreff: eb@aquasant-mt.com - Re: faild to build log4cxx => undefinde reference to `_imp__apr_xml_parse_file@20'
- Absender in Blocklist

 

Ervin, what env(OS and ver) do you use?

Do you compile using autotools?

On 8 Jul 2013 11:43, "Ervin Bajramovic" <eb@aquasant-mt.com> wrote:

Hi all

 

i am  trying to build log4cxx with mingw on windows xp, but i got this error:

 

g++ -g -O2 -o trivial.exe trivial.o  -L/usr/local/apr/lib -L/usr/local/lib -lshe

ll32 -ladvapi32 ../../../src/main/cpp/libs/liblog4cxx.a /usr/local/apr/lib/liba

prutil-1.a /usr/local/lib/libexpat.dll.a /usr/local/apr/lib/libapr-1.a -lws2_32

-lrpcrt4 -lmswsock -L/usr/local/lib -L/usr/local/lib

./../../src/main/cpp/.libs/liblog4cxx.a(domconfigurator.o): In function `ZN7log

4cxx3xml15DOMConfigurator11doConfigureERKNS_4FileERNS_7helpers10ObjectPtrTINS_3s

pi16LoggerRepositoryEEE':

C:\MinGW\msys\1.0\src\apache-log4cxx-0.10.0\src\main\cpp/domconfigurator.cpp:724

: undefined reference to `_imp__apr_xml_parse_file@20'

C:\MinGW\msys\1.0\src\apache-log4cxx-0.10.0\src\main\cpp/domconfigurator.cpp:733

: undefined reference to `_imp__apr_xml_parser_geterror@12'

collect2: ld gab 1 als Ende-Status zurück

make[3]: *** [trivial.exe] Error 1

make[3]: Leaving directory `/src/apache-log4cxx-0.10.0/src/examples/cpp'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/src/apache-log4cxx-0.100/src/examples'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/src/apache-log4cxx-0.10.0/src'

make: *** [all-recursive] Error 1

 

Any thoughts on what is going wrong.

 

Regards 

Ervin

 


Mime
View raw message