logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob L. Anawalt" <janaw...@geckosoftware.com>
Subject Re: apr installed
Date Thu, 12 Aug 2010 15:53:16 GMT
On 2010-08-12 07:24, Zuniga, Alessandro wrote:
> I’ve got apr installed. I added the location /apr-1.4.2/lib  to the 
> LD_LIBRARY_PATH and sourced it however, I still get the cannot find 
> –lapr-1 error, I also tried –libapr-1. In /apr-1.4.2/lib/ directory I 
> have apr.exp 
> 

When you compile, -l<name> says, look in the library search paths for 
lib<name>. The default paths are searched unless you use -L:

See the gcc man page for the -l and -L options. The Programming 
Library HOWTO may also be a worthwhile read for you.

http://tldp.org/HOWTO/Program-Library-HOWTO/shared-libraries.html

 > These servers are managed by a sys admin so I wouldn’t be able to
 > make any changes. Just wondering if everything is where it should
 > be.

"Where it should be" is subjective. I prefer to use any distribution 
package provided libraries where possible and install via their 
package manager. When I put on my sysadmin hat it makes my life easier 
to install and configure or uninstall the packaged non-LD_LIBRARY_PATH 
program on one or more similar systems.

There are other choices. The next two I consider are /opt island and 
/usr/local compile install. I dislike /usr compile install on a 
package managed system.

If you get your compile flags right and then if you monkey with the 
paths as you have you should be able to get it to work at runtime.

Best of luck,
-- 
Jacob Anawalt
Gecko Software, Inc.
janawalt@geckosoftware.com
435-752-8026

Mime
View raw message