logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@apache.org>
Subject Re: Can't build using Ant with MSVC 6.0
Date Wed, 27 Aug 2008 16:07:44 GMT

On Aug 27, 2008, at 6:48 AM, Moshe Matitya wrote:

> I am trying to build log4cxx 0.10.0 using ant, but the build fails  
> because of apr-util compilation errors.  Am I doing something wrong  
> here?
>
> I am using the following environment:
>
>     Micosoft Windows XP SP2
>     Microsoft Visual C/C++ 6.0 SP 6
>     Microsoft Platform SDK Feb. 2003
>     Apache Ant 1.7.1
>     AntContrib 1.0b3
>     CppTasks 1.0b5
>     log4cxx 0.10.0
>     apr 1.3.3
>     apr-util 1.3.4
>

The APR and APR-Util versions listed are substantially later than the  
ones that were current at the time of the log4cxx 0.10.0 release.  If  
I remember correctly, 1.2.12 was the current release, but compilation  
problems resulted in releasing against APR 1.2.11 and APR-Util  
1.2.10.  Does log4cxx build properly on your configuration with those  
versions of APR and APR-Util?  If so, then we can look at figuring out  
what has changed and how to either compensate or push the issue back  
to APR.

Mime
View raw message