logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dale King" <dalewk...@gmail.com>
Subject Re: Using the syslog appender in log4cxx
Date Fri, 06 Jun 2008 04:10:58 GMT
On Thu, Jun 5, 2008 at 10:18 PM, Curt Arnold <carnold@apache.org> wrote:
>
> On Jun 5, 2008, at 12:55 PM, Dale King wrote:
>>
>> That is a bug in version 0.10.0 Local 2 and higher was not implemented
>> correctly. See this difference to see the cut-and-paste error:
>>
>>
>> <http://svn.apache.org/viewvc/logging/log4cxx/trunk/src/main/cpp/syslogappender.cpp?r1=613005&r2=654960&pathrev=654960&diff_format=l>
>>
>> It has already been fixed in the trunk version of the repository. See
>> this revision:
>>
>> http://svn.apache.org/viewvc?view=rev&revision=654960
>
> Actually, that was a cosmetic error only.  It looked wrong, but there are no
> potential values for which the code would result in the wrong facility being
> assigned.
>


I saw that when you made the checkin, but I don't understand why you
think it is only a cosmetic bug. It seems to me that if you were
trying to configure a syslog appender for LOCAL2 for instance it would
call setFacility with LOCAL2 as the facility name. This would call
getFacility( "LOCAL2" ) which will not find a mapping for "LOCAL2" and
instead of returning the value LOG_LOCAL2 as it should it will return
LOG_UNDEF. This will cause the facility to default to USER.

I don't know anything about syslog to know what the ramifications of
that are, but I don't see how you can claim this behavior is merely
cosmetic.
-- 
Dale King

Mime
View raw message