logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Beaton" <olivier.bea...@gmail.com>
Subject Re: Problems building with MinGW
Date Fri, 27 Jun 2008 02:39:36 GMT
Thank you for taking the time to check it out Bob.

I've been pulling my hair out for 3 days over this.  I'm a bit
masochistic in that I wanted current to work (instead of just
backdating everything to some known working date, which is complicated
as the whole environment has to be backdated)

fyi with current MinGW/MSYS/MSYSDTK,

apr1.3.2, apr1.3.1, apr1.3.0 all failed in the same way.

apr1.2.9 fails with "decision on anonymous shared memory allocation
method failed"
but a post indicates I need crypt installed for this problem
http://mail-archives.apache.org/mod_mbox/tcl-rivet-dev/200212.mbox/%3CD981925B4F2CD611870300E0184CEE9B6E63FD@kaiserslautern1.lms-gmbh.de%3E
However the binary package wouldn't get detected by configure
(resulting in the same error) and despite installing bash and lndir to
compile crypt from the mingw source and applying the patch by hand I
got stuck in make.

Needless to say, I don't think I'll be able to get apr to compile (and
move on to seeing about apr-util, apr-iconv/libiconv and then finally
log4cxx!) until upstream is fixed.

Thanks for doing that work, I'll sit tight.

On 6/26/08, Bob Rossi <bob_rossi@cox.net> wrote:
>  > C:/msys/1.0/home/quadir/apr/include/arch/win32/apr_arch_misc.h:428:
>  > error: `lppe' undeclared (first use in this function)
>  > make[1]: *** [dso/win32/dso.lo] Error 1
>
> I just hit this same error. I'll have it fixed upstream, I'll let you
>  know when it's done.
>  Bob Rossi

Mime
View raw message