logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Beaton" <olivier.bea...@quadir.net>
Subject Re: Problems building with MinGW
Date Thu, 26 Jun 2008 23:01:03 GMT
Newbie here,

Built a brand new Windows XP SP3 machine,
Installed
MinGW 5.1.4
MSYS 1.0.10
msysDTK 1.0.1
python 2.5.2
expat 2.0.1 (built from source)

which gives me:
autoconf 2.56
automake 1.7.1
g++ 3.4.5
libtool 1.4e

trying to build log4cxx 0.10.0, which depends on expat, apr, apr-util.
Went to build apr from SVN HEAD today 2008-06-26, fails to build
(sorry I can't copy + paste the log from a non-internet machine)
Tried to build the lot with ant (provided by log4cxx) and apr builds
but apr-util doesn't.

>From there I went bleeding edge with the 4.x g++ on mingw site and
still couldn't get past apr.  I've spent 2 days now trying different
configurations (even mingwPORT libtool!) to no luck, perhaps I just
haven't hit the perfect combination yet.  I've tried using sources on
the websites for download or direct from SVN HEAD.

>From the messages by people like Bob Rossi and Curt Arnold it looks
like this is a frequent problem.

Does anyone know the current way to build 0.10.0?  I found a lot of
posts and guides from 1+ years ago but unfortunately they didn't
resolve the problem, as they were running into different stuff.

Sincerely,
Olivier Beaton

Mime
View raw message