logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From oncethor <antonio.chiri...@gmail.com>
Subject Re: Error building log4cxx on CentOS 5.1 X86_64
Date Mon, 26 May 2008 19:07:26 GMT

I was able to build log4cpp at last.
I had to hack the libtool utility.
1) First I renamed the original libtool in /usr/bin
2) redoing the "make" in the main directory does create another libtool, and
the compilation goes until the error on the library
3) at this point I hacked the libtool, changing *all* occurrences of
/usr/lib/ and /lib/ with a dummy name, like /usr/lib9000 and /lib9000
4) please note that also path like 
"/usr/lib9/gcc/x86_64-redhat-linux/4.1.2/../../../"
need to be changed, cause they point to /usr/lib/ anyway!!! Of course paths
like:
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../x86_64-redhat-linux/lib/x86_64-redhat-linux/4.1.2/
are ok.
5) re-run make, and now the compiler does not complain any more.

-oncethor



oncethor wrote:
> 
> Hello,
> 
> trying to compile log4cxx on a CentOS 5.1 x86_64 I get this error while
> linking:
> 
> /usr/lib/libdb-4.3.so: could not read symbols: File in wrong format
> 
> This is because the compiler tries to link the 32 bit version of the
> library.
> If I change the library with the 64bit version and put the file in the
> same /usr/lib directory, the linker gives another similar error on the
> expat lib.
> Doing the same job on the expat lib, solves the problem, and I can build
> log4cxx.
> 
> But then I can't use the other applications which work using the library
> on the /usr/lib directory.
> 
> I tried also to hack the libtool, changing all the references to /lib and
> /usr/lib directory into the /lib64 and /usr/lib64, but the problem
> remains.
> 
> Any ideas?
> 
> On the system I can see there are installed both the 32 and 64 bit version
> of the db-4.3 libraries:
> 
> 
> [root@gipserver3 ~]# yum list db4
> Loading "installonlyn" plugin
> Setting up repositories
> pidgin                    100% |=========================|  951 B    00:00     
> zeroc-ice                 100% |=========================|  951 B    00:00     
> extras                    100% |=========================| 1.1 kB    00:00     
> updates                   100% |=========================|  951 B    00:00     
> base                      100% |=========================| 1.1 kB    00:00     
> addons                    100% |=========================|  951 B    00:00     
> Reading repository metadata in from local files
> Installed Packages
> db4.x86_64                               4.3.29-9.fc6           installed       
> db4.i386                                 4.3.29-9.fc6           installed       
> 
> And if I try to delete the db4 I get:
> 
> [root@gipserver3 ~]# rpm -e db4.i386
> error: Failed dependencies:
>         libdb-4.3.so is needed by (installed) db4-devel-4.3.29-9.fc6.i386
>         libdb-4.3.so is needed by (installed) apr-util-1.2.7-6.i386
>         libdb-4.3.so is needed by (installed) subversion-1.4.2-2.el5.i386
>         libdb-4.3.so is needed by (installed) pam_ccreds-3-5.i386
>         libdb-4.3.so is needed by (installed) kdesdk-3.5.4-3.el5.i386
>         libdb-4.3.so is needed by (installed)
> evolution-data-server-1.8.0-25.el5.i386
>         libdb_cxx-4.3.so is needed by (installed)
> db4-devel-4.3.29-9.fc6.i386
> [root@gipserver3 ~]# rpm -e db4.x86_64
> error: Failed dependencies:
>         libdb-4.3.so()(64bit) is needed by (installed)
> iproute-2.6.18-4.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> db4-devel-4.3.29-9.fc6.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> python-2.4.3-19.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> apr-util-1.2.7-6.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> subversion-1.4.2-2.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> php-cli-5.1.6-15.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> sendmail-8.13.8-2.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> webalizer-2.01_10-30.1.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> mod_perl-2.0.2-6.3.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> pam_ccreds-3-5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> kdesdk-3.5.4-3.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> kdevelop-3.3.4-1.fc6.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> evolution-data-server-1.8.0-25.el5.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> perl-5.8.8-10.el5_0.2.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> httpd-2.2.3-11.el5_1.centos.3.x86_64
>         libdb-4.3.so()(64bit) is needed by (installed)
> openoffice.org-core-2.0.4-5.4.26.x86_64
>         libdb_cxx-4.3.so()(64bit) is needed by (installed)
> db4-devel-4.3.29-9.fc6.x86_64
>         libdb_cxx-4.3.so()(64bit) is needed by (installed)
> kdeaddons-3.5.4-1.fc6.x86_64
> 
> -Antonio
> 
> 

-- 
View this message in context: http://www.nabble.com/Error-building-log4cxx-on-CentOS-5.1-X86_64-tp17461854p17477504.html
Sent from the Log4cxx - Users mailing list archive at Nabble.com.


Mime
View raw message