logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kamdar, Devang \(MLITS\)" <Devang_Kam...@ml.com>
Subject RE: Problems converting std::string to LogString
Date Thu, 22 Nov 2007 15:07:47 GMT
All,
Its resolved now.
The problem was with a VC++ setting
Project -> Properties -> C/C++ -> Language -> Treat wcaht_t as Built-in
Type was "Yes" 
I changed it to "No (Zc:wchar_t-)" and Bingo! Its built fine.

Now I am facing another problem, which I will raise in a new thread and
the quest to test log4cxx continues .... :)

Thanks all for your help.
______________________________

Devang Kamdar

-----Original Message-----
From: Kamdar, Devang (MLITS) 
Sent: Wednesday, November 21, 2007 10:05 PM
To: Log4CXX User
Subject: RE: Problems converting std::string to LogString


Thanks a lot Curt for the reply.
I will try out the options.
For rev 597066, should that be built in the nightly builds?
I mean, if I download the latest build, I should be able to see these
changes right?
I am not trying to build in Windows, cos it seems a very long task
building on windows, as there are lot of pre-reqs like Ant, Mingw etc
... 
Anyways, the builds are working for me right now.
______________________________

Devang Kamdar
MSR Production Support.
For Urgent MSR Issues - Please contact the Person on Call from the
schedule in the link below:
http://confluence.worldnet.ml.com:8088/display/MSGCOE/Production+Support
+Rota


-----Original Message-----
From: Curt Arnold [mailto:carnold@apache.org] 
Sent: Wednesday, November 21, 2007 6:42 PM
To: Log4CXX User
Subject: Re: Problems converting std::string to LogString



On Nov 21, 2007, at 3:30 AM, Kamdar, Devang ((MLITS)) wrote:

> Hi,
> 911!
> Any acknowledgement or help highly appreciated.
> I have come to a point where I cannot think of anything anymore to
> resolve this mundane issue.
> I am sure, I am forgetting or overlooking something very silly.
> ______________________________
>
> Thanks
> Devang Kamdar
>


DLL exported templated functions are touchy.  I wasn't able to  
reproduce the problem, but went ahead and simplified transcoder to  
eliminate the exposed templated function definitions in rev 597066.   
If that doesn't work, try using the core function directly:

void Transcoder::decode(const char* src, size_t srcLen, LogString&)

If that doesn't work, open the DLL with Depends (in the start menu  
under Visual Studio/Tools) and check that the function appears in the  
export table for the DLL (around ordinal 1548 in mine).
--------------------------------------------------------

This message w/attachments (message) may be privileged, confidential or
proprietary, and if you are not an intended recipient, please notify the
sender, do not use or share it and delete it. Unless specifically
indicated, this message is not an offer to sell or a solicitation of any
investment products or other financial product or service, an official
confirmation of any transaction, or an official statement of Merrill
Lynch. Subject to applicable law, Merrill Lynch may monitor, review and
retain e-communications (EC) traveling through its networks/systems. The
laws of the country of each sender/recipient may impact the handling of
EC, and EC may be archived, supervised and produced in countries other
than the country in which you are located. This message cannot be
guaranteed to be secure or error-free. This message is subject to terms
available at the following link:
http://www.ml.com/e-communications_terms/. By messaging with Merrill
Lynch you consent to the foregoing.
--------------------------------------------------------

Mime
View raw message