logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomasz NoiƄski <n...@sphere.pl>
Subject log4cxx on ia64 and MutexException
Date Tue, 20 Nov 2007 21:55:01 GMT
Hi list,


I've been using log4cxx for one project (pre-apache version 0.9.7,
from official Debian packages). Recently I had to run this project on a
ia64 server (instead of a regular x86).
On ia64, this version of log4cxx simply segfaulted before even
outputting anything.

I knew this version was rather old, so I tried the svn.
I downloaded revision 596412 and compiled it without problems.
This time there was no segmentation fault, but the program was killed 
by a "MutexException".
I tested it with a simple "helloworld" program:
--- 8< ---
#include "log4cxx/logger.h"
#include "log4cxx/basicconfigurator.h"
int main() {
        log4cxx::LoggerPtr logger(log4cxx::Logger::getLogger("x"));
        log4cxx::BasicConfigurator::configure();
        LOG4CXX_INFO(logger, "hello world");
}
--- 8< ---

The exact result was:
--- 8< ---
0 [0x20000000016d4420] INFO x null - hello world
terminate called after throwing an instance of
'log4cxx::helpers::MutexException' what():  Mutex exception: stat = 22
Aborted
--- 8< ---

I thought it might have been a problem with this revision and not ia64
arch, so I tried the same revision on a regular PC. The same
"helloworld" program _didn't_ crash on ia32.


My questions are:
- is ia64 architecture supported?
- should I try other svn revisions? which ones?
- how could I help to track this bug down? I'll be happy to run it
through gdb etc. if it could help


Some details about the system it crashes on:
- Itanium2 processor (x86_64)
- Debian Etch (ia64 version)
- gcc 4.2.3 (also tries with gcc 4.1.2, same results)
- Linux kernel 2.6.18


Thanks in advance,

Noix

Mime
View raw message