logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From p...@mu.org
Subject Re: Race condition with FileAppender.
Date Sat, 30 Jun 2007 13:32:31 GMT
On Sat, Jun 30, 2007 at 12:32:11AM -0500, Curt Arnold wrote:
> What indicates to you that the problem is in FileAppender and not in  
> PatternLayout?  I would think that PatternLayout would be a might  
> more likely source of problems.  Have you tried other appenders  
> (telnet might be reasonable) and not had the problem?  Have you tried  
> a custom layout (all the stock layouts are preconfigured  
> PatternLayout's)?  Does the same issue still appear if you simplify  
> the pattern (maybe down to just %m or %m%n)?

I'm still very new to log4cxx internals and all the options.  I just
learned enough to get it to do what I needed---back with log4cxx9.  

So, I'm afraid I don't have any insight at all into what might be
causing the race condition.  And I haven't used any other appenders or
layouts.

I tried to just put %m%n in the pattern, per your request,  and I've attached the results
of the root log so you can see what I'm talking about.  As you'll see
there are lots of valid lines, then just junk, then more good lines.
See attached.

I've also added my log4cxx.properties.  If you want to make any changes
and define some different appenders or whatever, and mail it back, I can run it for you and
send you the results.

Please let me know if there is anything else I can do.

Thanks,

Pete






Mime
View raw message