Hi I am getting the following error when running ./autogen.sh on linux Red Hat Enterprise Linux AS release 3 (Taroon Update 4)

I see that some people had the same error but  I don't really understand how to solve it. Thank you for your help

I am using:
GNU m4 1.4.1
Aclocal 1.9.5
Autoversion 2.59
autoconf 2.59
Automake 1.9.5

bash-2.05b$ ./autogen.sh
aclocal:configure.in:32: warning: macro `AM_PROG_LIBTOOL' not found in library
Use of uninitialized value in concatenation (.) or string at /tools/gnu/autoconf-2.59/share/autoconf/Autom4te/XFile.pm line 229.

Use of uninitialized value in concatenation (.) or string at /tools/gnu/autoconf-2.59/share/autoconf/Autom4te/XFile.pm line 229.

Use of uninitialized value in concatenation (.) or string at /tools/gnu/autoconf-2.59/share/autoconf/Autom4te/XFile.pm line 229.

configure.in:32: error: possibly undefined macro: AM_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
Use of uninitialized value in concatenation (.) or string at /tools/gnu/autoconf-2.59/share/autoconf/Autom4te/XFile.pm line 229.

configure.in: installing `./install-sh'
configure.in: installing `./missing'
examples/Makefile.am: installing `./depcomp'
src/Makefile.am:1: Libtool library used but `LIBTOOL' is undefined
src/Makefile.am:1:
src/Makefile.am:1: The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
src/Makefile.am:1: to `configure.in' and run `aclocal' and `autoconf' again.


If you are not an intended recipient of this e-mail, please notify the sender, delete it and do not read, act upon, print, disclose, copy, retain or redistribute it. Click here for important additional terms relating to this e-mail.     http://www.ml.com/email_terms/