logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Crescioli, Phil" <Phil.Cresci...@gd-ais.com>
Subject RE: Linux RedHat 9.0
Date Tue, 28 Jun 2005 20:44:07 GMT
John, all,
I have noticed that my log4cxx version is buggy and I would upgrade
but I am testing a delivery of software that is delivered to my Co.
and I cant change the baseline sent to me just yet. I want to prove or
disprove
this is a log4j bug and that the delivered set of software and utils 
don't work as provided to me before I go changing and making it work
myself.

I'd still appreciate any other reply's to my email below as to if this
is my config prob or indeed a stopping point with log4cxx ver 0.9.7.
Thanks,
Phil


>>-----Original Message-----
>>From: Pauley, John C [mailto:John.Pauley@NielsenMedia.com] 
>>Sent: Tuesday, June 28, 2005 3:50 PM
>>To: Log4CXX User
>>Subject: RE: Linux RedHat 9.0
>>
>>
>>First thing I would suggest is getting the latest sources 
>>from CVS.  It is noted on log4cxx homepage that 0.9.7 
>>"substantially out of date, has known serious deficiencies 
>>that have been resolved in the CVS".
>>
>>Regards,
>>John 
>>
>>________________________________
>>
>>From: Crescioli, Phil [mailto:Phil.Crescioli@gd-ais.com] 
>>Sent: Tuesday, June 28, 2005 3:40 PM
>>To: log4cxx-user@logging.apache.org
>>Subject: Linux RedHat 9.0
>>
>>
>>
>>All, 
>>I'm a new log4cxx user. 
>>I noticed on the apache web site the log4cxx version 0.9.7 I 
>>have is buggy with 
>>respect to log4cxx initialization and I'm having probs and 
>>would appreciate 
>>any feedback on if my prob is a bug or me doing something wrong. 
>>
>>My env is: RHLinux9.0, with log4j.properties in the 
>>same dir as my exe that has hooks to log4cxx. 
>>
>>When I run my exe I get the following error: 
>>
>>Could not instantiate class [org.apache.log4j.FileAppender] 
>>Class 'org.apache.log4j.FileAppender' not found 
>>
>>Is this saying my liblog4cxx.a library I'm linking to my exe does 
>>not contain a needed class?  If so, how do I rebuild liblog4cxx.a 
>>so it see's the needed class? 
>>
>>Is this just a log4.properties config error on my part? 
>>Any help is appreciated. 
>>
>>Phil 
>>
>>
>>

Mime
View raw message