logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@houston.rr.com>
Subject Re: Compiling log4cxx on OS X 10.3.9
Date Fri, 13 May 2005 16:35:33 GMT
I haven't rebuild on Mac since I did those and just started doing  
some quick reading.  Having those symbols undefined is an intentional  
indication that the code could not recognize the wchar_t as one of  
the two currently supported mappings, UTF-16LE (for Windows, detected  
when _WIN32 is defined) and UCS-4 (when __STD_ISO_10646... is  
defined).  I haven't figured out exactly what wchar_t is on the Mac  
platform (it suggests CFString to be used in place of wstring).   
Until I can cycle over to the Mac (I do a slow iteration among  
platforms), I would suggest that you build log4cxx with use of  
wchar_t disabled.

ant -Dhas.wchar_t=0




On May 13, 2005, at 10:51 AM, Juri Ganitkevitch wrote:

> First off, thanks a lot!
>
> This resolves the libiconv error (actually I should have found this  
> myself, I saw after looking at the first 10 lines
> of build.xml, sorry).
>
> The change you pointed out leads to another linker error, this time  
> related to log4cxx itself:
>
>        [cc] ld: Undefined symbols:
>        [cc] log4cxx::helpers::UnicodeHelper::decodeWide(wchar_t  
> const*&, wchar_t const*)
>        [cc] log4cxx::helpers::UnicodeHelper::encodeWide(unsigned  
> int, wchar_t*)
>        [cc] /usr/bin/libtool: internal link edit command failed
>
> This is not related to the
>
> #if LOG4CXX_HAS_WCHAR_T
>
> around them (tried without, same result).
>
> Do you have any suggestions??
>
> Again, thank you for the fast and helpful reply!!
>
> Greetings,
>
> Juri
>
>
>


Mime
View raw message