logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@houston.rr.com>
Subject Re: Segmentation fault on Linux
Date Fri, 22 Apr 2005 19:47:23 GMT
Several times a day, Gump builds log4cxx on a Debian Linux and runs a 
suite of unit tests.  On one of those runs, it will send an email 
message to the list if the build failed for any reason.  There was an 
example of this last night when the recent changes cause the compile to 
fail when log4cxx was build using UTF-8 for logchar instead of wchar_t 
(the normal build using wchar_t as logchar worked fine).

Obviously the changes needed to add encoding support for Win32 without 
using apr-iconv could have introduced problems.  However, since it 
passed the unit tests and ran the examples successfully, the problem 
may only occur under particular conditions and more details on the 
failure would be needed to analyze the problem.


On Apr 22, 2005, at 2:27 PM, Thierry Lam wrote:

>
> Has anyone tried running the current CVS HEAD of log4cxx on Linux? I'm
> getting segmentation fault and it seems to be coming from the config
> file at line 2 below when I try to use the appender.  My program runs
> fine with no logging.
>
>
> log4j.rootLogger=DEBUG, stdout
> log4j.appender.stdout=org.apache.log4j.ConsoleAppender
>
>
> I'm currently using the following version of Linux:
>
> Red Hat Linux release 9 (Shrike)
> Kernel 2.4.20-6 on an i686
>
>
>
> Thierry
>


Mime
View raw message