logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@apache.org>
Subject Re: Current cvs version not working properly
Date Wed, 20 Apr 2005 21:05:58 GMT
As previously mentioned in:

http://marc.theaimsgroup.com/?l=log4cxx-dev&m=111233291509541&w=2
http://marc.theaimsgroup.com/?l=log4cxx-user&m=111341204400257&w=2
http://marc.theaimsgroup.com/?l=log4cxx-user&m=111368947708423&w=2

the CVS HEAD is broken on Windows due to shortcomings in apr-iconv on 
Windows and will remain broken until I complete alternative 
implementations for charset encoding and decoding.  Until that is fixed 
(which I am working on at the moment), the Windows build is not usable 
for even the most basic use.  Until that time, hopefully within 24 
hours, you will need to grab a copy from 31-March-2005 or earlier to 
work on Windows.  The problem does not affect platforms that have a 
native ICONV implementation.



On Apr 20, 2005, at 3:46 PM, Thierry Lam wrote:

> I did cvs checkout on the latest version of log4cxx codes and my build 
> failed after running ant:
> run-unittest:
>  
>  
>  
> BUILD FAILED
> C:\logging-log4cxx\build.xml:921: exec returned: 3
>  
> There’s also a pop up error like the following:
>  
> Debug Error!
>  
> Program: C:\logging-log4cxx\build\debug\shared\log4cxx-test.exe
>  
> I’m assuming the above is probably failing on some test cases.  I 
> thought it won’t affect my project, so I tried the following in my 
> project:
>  
> LoggerPtr logger(Logger::getLogger("MyApp"));
>  
> It compiles fine but when I try to run my program, it fails.  After 
> debugging it, I found out that getLogger() was not working properly, 
> something was failing deep inside. 
>  
> Is there some stable version of log4cxx for now? If not, is there an 
> ETA when that will happen?
>  
> Thierry


Mime
View raw message