logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Murison <tmuri...@primus.ca>
Subject Re: CVS Head build trouble
Date Fri, 15 Apr 2005 15:22:44 GMT
Thanks for the fix.

Now I feel __really__ stupid asking this question...
how do I install log4cxx once the ant build is complete?

make install won't work obviously, and I don't see an ant target to
install. I'm thinking of manually copying the library and the include
directory to /usr/local, but that seem sketchy...

Cheers,

-Tim

On Fri, 2005-15-04 at 09:22 -0400, jwert@ilstechnology.com wrote:
> Tim,
> 
> I saw this problem too.  To solve it, goto the
> logging-log4cxx/lib/apr-iconv-1.0.1 directory and run the configure script
> manually with ./configure.  You'll have to do the same thing for the
> apr-util package as well.  After doing that, the build was successful for
> me.
> 
> Thanks,
> 
> James Wert Jr.
> JWert@ILSTechnology.com
> 
> 
> 
> |---------+---------------------------->
> |         |           Tim Murison      |
> |         |           <tmurison@primus.|
> |         |           ca>              |
> |         |                            |
> |         |           04/15/2005 01:49 |
> |         |           AM               |
> |         |           Please respond to|
> |         |           "Log4CXX User"   |
> |---------+---------------------------->
>   >------------------------------------------------------------------------------------------------------------------------------------|
>   |                                                                                 
                                                  |
>   |       To:       log4cxx-user@logging.apache.org                                 
                                                  |
>   |       cc:                                                                       
                                                  |
>   |       Subject:  CVS Head build trouble                                          
                                                  |
>   >------------------------------------------------------------------------------------------------------------------------------------|
> 
> 
> 
> 
> Hi all,
> 
> I am having some trouble building the CVS HEAD using ant under
> Linux/Debian.
> 
> I have taken CVS HEAD of ant-contrib and cpptasks and built those, and
> set them on the classpath.
> When I invoke ant, the build fails with:
> 
> /home/tmurison/S-W/logging-log4cxx/apriconv-build.xml:192: gcc failed
> with return code 1
> 
> The compiler errors seem to indicate problem finding header files in the
> apr-iconv library.
> 
> Any ideas?
> 
> -Tim
> 
> 
> 
> 
> 
> 
> 


Mime
View raw message