logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prakash Kadam" <pka...@nulinkinc.com>
Subject RE: ODBCppender problem
Date Tue, 15 Feb 2005 06:26:21 GMT

Hello, sir
 ie u r not use the xml confiurator for ODBCAppender.If yes then send me that sample file
,please .....



-----Original Message-----
From:	Tim Murison [mailto:tmurison@primus.ca]
Sent:	Tue 2/15/2005 11:42 AM
To:	Log4CXX User
Cc:	
Subject:	RE: Odd problem
Can't help you there. I am using MySQL and talking to the DB via MySQL
++. The logging statements I issue are just to files.

On Tue, 2005-15-02 at 10:50 +0530, Prakash Kadam wrote:
> Hi,
>   Sorry i don't hae solution but, i have initail problem for connecting with databse
(Postgresql). So can u tell me how to connect with database from log4cxx (ODBCAppender).
> Please,
> 
> Regards 
> Prakash
> 
> 
> -----Original Message-----
> From:	Tim Murison [mailto:tmurison@primus.ca]
> Sent:	Tue 2/15/2005 9:41 AM
> To:	log4cxx-user@logging.apache.org
> Cc:	
> Subject:	Odd problem
> Hi,
> 
> I'm hoping someone might be able to shed some light on this...
> 
> I have a function that executes a DB query and returns a vector<string>
> of the results. I have just started to add logging to my program, so
> just before returning the vector, I issue a logging statement:
> 
> LOG4CXX_INFO(logger, "Done read query");
> 
> Here the weird bit. If I comment out the logging statement, the vector
> elements are something like:
> 	[1, OBJECT, 2]
> With the logging statement the elements are:
> 	[1, Done read query, 2]
> 
> I am using log4cxx 0.9.7. I have tried compiling CVS HEAD, but it fails
> with some scary messages (both using autogen and ant).
> 
> Any ideas?
> 
> Cheers,
> 
> -Tim
> 
> 
> 
> 





Mime
View raw message