logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Surekha Guntur <guntur_sure...@yahoo.com>
Subject Re: Solaris compilation problem...
Date Wed, 01 Sep 2004 16:10:23 GMT
Thank you very much for your suggestions. Now I could build log4cxx on solaris successfully.
But when I try to run a sample example 'trivial' (in src/exapmles) I get the following error.
It just has BasicConfigurator.
--------
You have tried to set a null level to root.
Segmentation Fault (core dumped)
--------
 
Any ideas please... I am using log4cxx-0.9.7 version. Do I need to supply any configuration
file or set any environment variables. I tried to set log4j.configuration environment variable.
But it does not take this as it has '.' (dot) in it. Has anyone come across this problem?
 
Thanks,
Surekha.

"Sven A.Schmidt" <sas@abstracture.de> wrote:
This might be unrelated, but I've had loads of trouble with linking 
STL/template code on Solaris. Using the compiler switch 
"-instances=static" fixed all my problems. Found here:



HTH,
Sven


On 31.08.2004, at 19:42, Surekha Guntur wrote:

> Hi,
>  
> I am trying to build log4cxx on Sun solaris and I am getting following 
> problems. I have used following following flags for configure script.
>  
> ./configure CC=CC CXX=CC CXXFLAGS="-g -mt -KPIC -xarch=v8plus"
>  
> Following are the errors I get while doing 'make'. There are many 
> undefined symbols similar to these. Can somebody please help me on 
> this.
>  
> ild: (undefined symbol) 
> log4cxx::helpers::ObjectPtrT> ector>&log4cxx::helpers::ObjectPtrT> RepositorySelector>::operator=
> (const __type_1&) -- 
> referenced in ../
> src/.libs/liblog4cxx.so
> ild: (undefined symbol) void 
> log4cxx::helpers::ObjectPtrT> ct>::cast(const __type_1&) -- 
> referenced in ../sr
> c/.libs/liblog4cxx.so
> ild: (undefined symbol) 
> log4cxx::helpers::ObjectPtrT> nverter>&log4cxx::helpers::ObjectPtrT> PatternConverter>::opera
> tor=(const 
> __type_1&)
>  -- referenced in ../src/.libs/liblog4cxx.so
> *** Error code 5
> make: Fatal error: Command failed for target `simplesocketserver'
> Current working directory /csf/csf/w951bdz/log4cxx/log4cxx-0.9.7/src
> *** Error code 1
> make: Fatal error: Command failed for target `all-recursive'
>  
> Thanks a lot,
>  
> Surekha.
>
> Do you Yahoo!?
> New and Improved Yahoo! Mail - Send 10MB messages!


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
Mime
View raw message