logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barak Simon" <barak.si...@db.com>
Subject You have tried to set a null level to root(2)
Date Fri, 30 Jul 2004 07:42:59 GMT
Hi Michael,

It seems this problem of "You have tried to set a null level to root" is happening
to us on gcc 3.2.2 while linking to the shared version of the logging (0.9.7) library (haven't
tried the static version).

(The using library code is a bit complex, so I will need some time to try and generate it
on simpler cases -- sorry about that;
it basically happens when trying to create a configurator, regardless of its type)

Since I do not know any #pragma hack to enforce static order for gcc, I wonder if there is
anything we can do about it.
Around May you wrote in the mailing list that you may re-design the static initialisation
part - how is that going, and are there any tips you
can provide us with to locally patch it for the interim until a formal release is out?

Many thanks,
Barak
________________________
Barak Simon
GED IT Core Platform
190 George St. Sydney, 2000
Deutsche Bank
Phone +61 2 925 85070
Fax      +61 2 925 95050


--

This e-mail may contain confidential and/or privileged information. If you are not the intended
recipient (or have received this e-mail in error) please notify the sender immediately and
destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material
in this e-mail is strictly forbidden.



Mime
View raw message