logging-log4cxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John.E.Gr...@wellsfargo.com
Subject Compiling 0.9.7 under cygwin
Date Wed, 26 May 2004 22:23:13 GMT
Hi all,

I'm trying to compile 0.9.7 under Cygwin on Windows 2000.  At first,
configure failed with a message with a message about not being able to find
an input file but which file wasn't named.  I changed 4 lines like this:
echo "$as_me: error: cannot find input file: $f" >&2;} To this: echo
"$as_me:$LINENO: error: cannot find input file: $f" >&2;}

That seemed to get around that problem.  Incidentally, I don't know why that
worked, I thought I was just adding some debug info.

After I got configure to work, compilation failed by complaining about line
48 of tchar.h.  I thought at first the problem was that WIN32 was not
defined anywhere.  I tried adding #define WIN32 1 to config.h and
config_auto.h but it didn't matter.

I see instructions on using some Microsoft IDEs to compile but not for
Cygwin.  Can someone give me a hint?  I'm not a C/C++ programmer, so go easy
on me!


Thanks


Here's the exact output of my compilation failures:

$ make
Making all in docs
make[1]: Entering directory `/cygdrive/c/temp/log4cxx-0.9.7/docs'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/cygdrive/c/temp/log4cxx-0.9.7/docs'
Making all in src
make[1]: Entering directory `/cygdrive/c/temp/log4cxx-0.9.7/src'
if /bin/bash ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I.
-I../include/ log4cxx -I../include -I/usr/include/libxml2  -D_REENTRANT  -g
-O2 -MT appenderat tachableimpl.lo -MD -MP -MF
".deps/appenderattachableimpl.Tpo" \
  -c -o appenderattachableimpl.lo `test -f 'appenderattachableimpl.cpp' ||
echo './'`appenderattachableimpl.cpp; \ then mv -f
".deps/appenderattachableimpl.Tpo" ".deps/appenderattachableimpl.Plo"
; \
else rm -f ".deps/appenderattachableimpl.Tpo"; exit 1; \
fi
 g++ -DHAVE_CONFIG_H -I. -I. -I../include/log4cxx -I../include
-I/usr/include/li bxml2 -D_REENTRANT -g -O2 -MT appenderattachableimpl.lo
-MD -MP -MF .deps/append erattachableimpl.Tpo -c appenderattachableimpl.cpp
-DPIC -o .libs/appenderattac hableimpl.o In file included from
appenderattachableimpl.cpp:17:
../include/log4cxx/helpers/tchar.h: In static member function `static void
   Convert::int64ToString(wchar_t*, unsigned int, const int64_t&)':
../include/log4cxx/helpers/tchar.h:48: error: `_snwprintf' undeclared (first
   use this function)
../include/log4cxx/helpers/tchar.h:48: error: (Each undeclared identifier is
   reported only once for each function it appears in.)
../include/log4cxx/helpers/tchar.h: In static member function `static void
   Convert::int64ToString(char*, unsigned int, const int64_t&)':
../include/log4cxx/helpers/tchar.h:57: error: `_snprintf' undeclared (first
use

   this function)
make[1]: *** [appenderattachableimpl.lo] Error 1
make[1]: Leaving directory `/cygdrive/c/temp/log4cxx-0.9.7/src'
make: *** [all-recursive] Error 1

John Gregg
Web Developer
Wells Fargo/Mortgage IT
Minneapolis, MN

Mime
View raw message