kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From guozh...@apache.org
Subject [kafka] branch 2.5 updated: MINOR: Port streams broker compatibility fix (#8203)
Date Mon, 02 Mar 2020 17:27:48 GMT
This is an automated email from the ASF dual-hosted git repository.

guozhang pushed a commit to branch 2.5
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/2.5 by this push:
     new 3f99f9d  MINOR: Port streams broker compatibility fix (#8203)
3f99f9d is described below

commit 3f99f9dd910a6d858d3d2541db6be1f1e5d93ec5
Author: John Roesler <vvcephei@users.noreply.github.com>
AuthorDate: Mon Mar 2 11:27:17 2020 -0600

    MINOR: Port streams broker compatibility fix (#8203)
    
    Reviewers: Guozhang Wang <wangguoz@gmail.com>
---
 .../tests/streams/streams_broker_compatibility_test.py       | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
index fb2c72b..cb2a7a5 100644
--- a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
+++ b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
@@ -54,7 +54,7 @@ class StreamsBrokerCompatibility(Test):
     def setUp(self):
         self.zk.start()
 
-   
+
     @parametrize(broker_version=str(LATEST_0_10_2))
     @parametrize(broker_version=str(LATEST_0_10_1))
     def test_fail_fast_on_incompatible_brokers_if_eos_enabled(self, broker_version):
@@ -79,8 +79,6 @@ class StreamsBrokerCompatibility(Test):
     @parametrize(broker_version=str(LATEST_1_1))
     @parametrize(broker_version=str(LATEST_1_0))
     @parametrize(broker_version=str(LATEST_0_11_0))
-    @parametrize(broker_version=str(LATEST_0_10_2))
-    @parametrize(broker_version=str(LATEST_0_10_1))
     def test_compatible_brokers_eos_disabled(self, broker_version):
         self.kafka.set_version(KafkaVersion(broker_version))
         self.kafka.start()
@@ -97,6 +95,8 @@ class StreamsBrokerCompatibility(Test):
         self.consumer.stop()
         self.kafka.stop()
 
+    @parametrize(broker_version=str(LATEST_0_10_2))
+    @parametrize(broker_version=str(LATEST_0_10_1))
     @parametrize(broker_version=str(LATEST_0_10_0))
     def test_fail_fast_on_incompatible_brokers(self, broker_version):
         self.kafka.set_version(KafkaVersion(broker_version))
@@ -106,9 +106,9 @@ class StreamsBrokerCompatibility(Test):
 
         with processor.node.account.monitor_log(processor.STDERR_FILE) as monitor:
             processor.start()
-            monitor.wait_until('FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support CREATE_TOPICS',
-                        timeout_sec=60,
-                        err_msg="Never saw 'FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support CREATE_TOPICS' error message " + str(processor.node.account))
+            monitor.wait_until('FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException',
+                               timeout_sec=60,
+                               err_msg="Never saw 'FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException
" + str(processor.node.account))
 
         self.kafka.stop()
 


Mime
View raw message