kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ij...@apache.org
Subject [kafka] branch trunk updated: MINOR: Update minimum required Gradle version to 4.7 (#5642)
Date Thu, 13 Sep 2018 14:39:04 GMT
This is an automated email from the ASF dual-hosted git repository.

ijuma pushed a commit to branch trunk
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/trunk by this push:
     new df35c22  MINOR: Update minimum required Gradle version to 4.7 (#5642)
df35c22 is described below

commit df35c22eac2b0d067263378d0d7251fe9b1418a6
Author: Stanislav Kozlovski <stanislav_kozlovski@outlook.com>
AuthorDate: Thu Sep 13 17:38:53 2018 +0300

    MINOR: Update minimum required Gradle version to 4.7 (#5642)
    
    After commit f123d2f, the minimum required gradle version changed to 4.7
    
    This is due to the use of isJava11Compatible() in build.gradle. It was
    introduced in version 4.7 (https://github.com/gradle/gradle/blob/master/subprojects/base-services/src/main/java/org/gradle/api/JavaVersion.java#L172-L180)
    
    Reviewers: Ismael Juma <ismael@juma.me.uk>
---
 README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/README.md b/README.md
index 22ef66f..4e8c149 100644
--- a/README.md
+++ b/README.md
@@ -4,7 +4,7 @@ See our [web site](http://kafka.apache.org) for details on the project.
 
 You need to have [Gradle](http://www.gradle.org/installation) and [Java](http://www.oracle.com/technetwork/java/javase/downloads/index.html)
installed.
 
-Kafka requires Gradle 4.6 or higher.
+Kafka requires Gradle 4.7 or higher.
 
 Java 8 should be used for building in order to support both Java 8 and Java 10 at runtime.
 


Mime
View raw message