kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From guozh...@apache.org
Subject [kafka] branch trunk updated: MINOR: Relax Unsupported Version check on BrokerCompatibilityTest (#5170)
Date Mon, 11 Jun 2018 22:45:45 GMT
This is an automated email from the ASF dual-hosted git repository.

guozhang pushed a commit to branch trunk
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/trunk by this push:
     new a20c8e8  MINOR: Relax Unsupported Version check on BrokerCompatibilityTest (#5170)
a20c8e8 is described below

commit a20c8e87605edc759a452f6eee79df901a9aafa6
Author: Guozhang Wang <wangguoz@gmail.com>
AuthorDate: Mon Jun 11 15:45:29 2018 -0700

    MINOR: Relax Unsupported Version check on BrokerCompatibilityTest (#5170)
    
    In BrokerCompatibilityTest.java, when older versioned broker is used (0.10.1, 0.10.2),
LIST_OFFSET is not supported as well. Hence in the verification phase, there is a possibility
that consumer hit the UnsupportedVersionException earlier than Streams actually hits it:
    
    org.apache.kafka.common.errors.UnsupportedVersionException: The broker does not support
LIST_OFFSETS with version in range [2,3]. The supported range is [0,1].
    
    While the test is waiting for
    
    org.apache.kafka.common.errors.UnsupportedVersionException: Cannot create a v0 FindCoordinator
request because we require features supported only in 1 or later.
    
    Both are valid errors to expect (the former is from consumer while the latter is from
producer of the streams app).
    
    Reviewers: John Roesler <john@confluent.io>, Matthias J. Sax <matthias@confluent.io>,
Bill Bejeck <bill@confluent.io>
---
 tests/kafkatest/tests/streams/streams_broker_compatibility_test.py | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
index 5370a39..67d9429 100644
--- a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
+++ b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
@@ -66,9 +66,9 @@ class StreamsBrokerCompatibility(Test):
 
         with processor.node.account.monitor_log(processor.STDERR_FILE) as monitor:
             processor.start()
-            monitor.wait_until('FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
Cannot create a v0 FindCoordinator request because we require features supported only in 1
or later.',
+            monitor.wait_until('FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException',
                                timeout_sec=60,
-                               err_msg="Never saw 'FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
Cannot create a v0 FindCoordinator request because we require features supported only in 1
or later.' error message " + str(processor.node.account))
+                               err_msg="Never saw 'FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException'
error message " + str(processor.node.account))
 
         self.kafka.stop()
 

-- 
To stop receiving notification emails like this one, please contact
guozhang@apache.org.

Mime
View raw message