kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ewe...@apache.org
Subject kafka git commit: KAFKA-4417: Update build dependencies for 0.10.2 cycle
Date Thu, 17 Nov 2016 22:43:12 GMT
Repository: kafka
Updated Branches:
  refs/heads/trunk eaf0e4af3 -> 079ea89b3


KAFKA-4417: Update build dependencies for 0.10.2 cycle

Notes on the updates:
* Gradle to 3.2: better incremental build and faster IDE import times (https://docs.gradle.org/3.2/release-notes)
* zkclient to 0.10: it now uses slf4j-api instead of log4j
* zookeeper to 3.4.9: a few important bug fixes (http://zookeeper.apache.org/doc/r3.4.9/releasenotes.html)
* jackson to 2.8.5: lots of updates (https://github.com/FasterXML/jackson/wiki/Jackson-Release-2.6,
https://github.com/FasterXML/jackson/wiki/Jackson-Release-2.7, https://github.com/FasterXML/jackson/wiki/Jackson-Release-2.8)
* jersey to 2.24: bug fixes (https://jersey.java.net/release-notes/2.23.html, https://jersey.java.net/release-notes/2.24.html)
* jopt to 5.0.3: minor improvements, the major version bump is due to requiring Java 7 instead
of 6 (https://pholser.github.io/jopt-simple/changes.html)
* argparse4j to 0.7.0: minor tweaks and improvements (https://github.com/tatsuhiro-t/argparse4j/blob/argparse4j-0.6.0/NEWS,
https://github.com/tatsuhiro-t/argparse4j/blob/argparse4j-0.7.0/NEWS)
* Gradle plugins
* bcpkix to 1.55: quite a few additions, but nothing that matters to us (http://www.bouncycastle.org/releasenotes.html)

Author: Ismael Juma <ismael@juma.me.uk>

Reviewers: Ewen Cheslack-Postava <ewen@confluent.io>

Closes #2144 from ijuma/gradle-3.2-and-deps


Project: http://git-wip-us.apache.org/repos/asf/kafka/repo
Commit: http://git-wip-us.apache.org/repos/asf/kafka/commit/079ea89b
Tree: http://git-wip-us.apache.org/repos/asf/kafka/tree/079ea89b
Diff: http://git-wip-us.apache.org/repos/asf/kafka/diff/079ea89b

Branch: refs/heads/trunk
Commit: 079ea89b369f13d3c0edcab8dd3f6bd32a31983d
Parents: eaf0e4a
Author: Ismael Juma <ismael@juma.me.uk>
Authored: Thu Nov 17 14:43:00 2016 -0800
Committer: Ewen Cheslack-Postava <me@ewencp.org>
Committed: Thu Nov 17 14:43:00 2016 -0800

----------------------------------------------------------------------
 build.gradle               | 21 +++++++++++----------
 docs/ops.html              |  2 +-
 docs/security.html         |  2 +-
 gradle/dependencies.gradle | 14 +++++++-------
 gradle/rat.gradle          |  2 +-
 5 files changed, 21 insertions(+), 20 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kafka/blob/079ea89b/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index fded48e..bcc7bcc 100644
--- a/build.gradle
+++ b/build.gradle
@@ -24,8 +24,8 @@ buildscript {
 
   dependencies {
     // For Apache Rat plugin to ignore non-Git files
-    classpath "org.ajoberstar:grgit:1.5.0"
-    classpath 'com.github.ben-manes:gradle-versions-plugin:0.12.0'
+    classpath "org.ajoberstar:grgit:1.7.0"
+    classpath 'com.github.ben-manes:gradle-versions-plugin:0.13.0'
     classpath 'org.scoverage:gradle-scoverage:2.1.0'
   }
 }
@@ -68,7 +68,7 @@ allprojects {
 }
 
 ext {
-  gradleVersion = "3.0"
+  gradleVersion = "3.2"
   buildVersionFileName = "kafka-version.properties"
 
   maxPermSizeArgs = []
@@ -695,19 +695,20 @@ project(':streams') {
     compile project(':connect:json')  // this dependency should be removed after we unify
data API
     compile libs.slf4jApi
     compile libs.rocksDBJni
-    // this dependency should be removed after KIP-4
+
+    // the following 3 dependencies should be removed after KIP-4 (zkclient, zookeeper, jacksonDatabind)
     compile (libs.zkclient) {
+      exclude module: 'zookeeper'
+    }
+
+    compile (libs.zookeeper) {
+      exclude module: 'jline'
+      exclude module: 'netty'
       // users should be able to choose the logging implementation (and slf4j bridge)
       exclude module: 'slf4j-log4j12'
       exclude module: 'log4j'
-      exclude module: 'jline'
-      exclude module: 'netty'
     }
 
-    // zkclient has a hard log4j dependency, we set it here as well to avoid copying an older
-    // version to the binary package; the following two dependencies should be removed after
KIP-4
-    // (along with the zkclient dependency)
-    compile libs.log4j
     compile libs.jacksonDatabind
 
     testCompile project(':clients').sourceSets.test.output

http://git-wip-us.apache.org/repos/asf/kafka/blob/079ea89b/docs/ops.html
----------------------------------------------------------------------
diff --git a/docs/ops.html b/docs/ops.html
index c26f0cb..f0b659c 100644
--- a/docs/ops.html
+++ b/docs/ops.html
@@ -1340,7 +1340,7 @@ The final alerting we do is on the correctness of the data delivery.
We audit th
 <h3><a id="zk" href="#zk">6.7 ZooKeeper</a></h3>
 
 <h4><a id="zkversion" href="#zkversion">Stable version</a></h4>
-The current stable branch is 3.4 and the latest release of that branch is 3.4.8, which is
the one ZkClient 0.9 uses. ZkClient is the client layer Kafka uses to interact with ZooKeeper.
+The current stable branch is 3.4 and the latest release of that branch is 3.4.9.
 
 <h4><a id="zkops" href="#zkops">Operationalizing ZooKeeper</a></h4>
 Operationally, we do the following for a healthy ZooKeeper installation:

http://git-wip-us.apache.org/repos/asf/kafka/blob/079ea89b/docs/security.html
----------------------------------------------------------------------
diff --git a/docs/security.html b/docs/security.html
index 24cd771..f58179f 100644
--- a/docs/security.html
+++ b/docs/security.html
@@ -741,6 +741,6 @@ Here is an example of how to run the migration tool:
 <h4><a id="zk_authz_ensemble" href="#zk_authz_ensemble">7.6.3 Migrating the ZooKeeper
ensemble</a></h4>
 It is also necessary to enable authentication on the ZooKeeper ensemble. To do it, we need
to perform a rolling restart of the server and set a few properties. Please refer to the ZooKeeper
documentation for more detail:
 <ol>
-	<li><a href="http://zookeeper.apache.org/doc/r3.4.8/zookeeperProgrammers.html#sc_ZooKeeperAccessControl">Apache
ZooKeeper documentation</a></li>
+	<li><a href="http://zookeeper.apache.org/doc/r3.4.9/zookeeperProgrammers.html#sc_ZooKeeperAccessControl">Apache
ZooKeeper documentation</a></li>
 	<li><a href="https://cwiki.apache.org/confluence/display/ZOOKEEPER/Zookeeper+and+SASL">Apache
ZooKeeper wiki</a></li>
 </ol>

http://git-wip-us.apache.org/repos/asf/kafka/blob/079ea89b/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/gradle/dependencies.gradle b/gradle/dependencies.gradle
index 79e1689..79bb7de 100644
--- a/gradle/dependencies.gradle
+++ b/gradle/dependencies.gradle
@@ -25,14 +25,14 @@ ext {
 versions += [
   apacheda: "1.0.0-M33",
   apacheds: "2.0.0-M21",
-  argparse4j: "0.5.0",
-  bcpkix: "1.54",
+  argparse4j: "0.7.0",
+  bcpkix: "1.55",
   easymock: "3.4",
-  jackson: "2.6.3",
+  jackson: "2.8.5",
   jetty: "9.2.15.v20160210",
-  jersey: "2.22.2",
+  jersey: "2.24",
   log4j: "1.2.17",
-  jopt: "4.9",
+  jopt: "5.0.3",
   junit: "4.12",
   lz4: "1.3.0",
   metrics: "2.2.0",
@@ -44,8 +44,8 @@ versions += [
   scoverage: "1.3.0",
   slf4j: "1.7.21",
   snappy: "1.1.2.6",
-  zkclient: "0.9",
-  zookeeper: "3.4.8",
+  zkclient: "0.10",
+  zookeeper: "3.4.9",
 ]
 
 // Add Scala version

http://git-wip-us.apache.org/repos/asf/kafka/blob/079ea89b/gradle/rat.gradle
----------------------------------------------------------------------
diff --git a/gradle/rat.gradle b/gradle/rat.gradle
index 3ead016..a51876c 100644
--- a/gradle/rat.gradle
+++ b/gradle/rat.gradle
@@ -115,7 +115,7 @@ class RatPlugin implements Plugin<Project> {
       mavenCentral()
     }
     project.dependencies {
-      rat 'org.apache.rat:apache-rat-tasks:0.11'
+      rat 'org.apache.rat:apache-rat-tasks:0.12'
     }
   }
 }


Mime
View raw message