kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ewe...@apache.org
Subject kafka git commit: KAFKA-3227; Conservative update of Kafka dependencies
Date Tue, 16 Feb 2016 15:19:19 GMT
Repository: kafka
Updated Branches:
  refs/heads/trunk d7fc7cf61 -> f355918ec


KAFKA-3227; Conservative update of Kafka dependencies

Patch version bumps for bouncy castle, minikdc, snappy, slf4j, scalatest and powermock. Notable
fixes:

* Snappy: fixes a resource leak
* Bouncy castle: security fixes

Also update Gradle to 2.11 (where the notable change is improved IDE integration) and the
grgit build dependency.

Author: Ismael Juma <ismael@juma.me.uk>

Reviewers: Grant Henke <granthenke@gmail.com>, Ewen Cheslack-Postava <ewen@confluent.io>

Closes #903 from ijuma/kafka-3227-conservative-update-of-kafka-deps


Project: http://git-wip-us.apache.org/repos/asf/kafka/repo
Commit: http://git-wip-us.apache.org/repos/asf/kafka/commit/f355918e
Tree: http://git-wip-us.apache.org/repos/asf/kafka/tree/f355918e
Diff: http://git-wip-us.apache.org/repos/asf/kafka/diff/f355918e

Branch: refs/heads/trunk
Commit: f355918ec7edd6cfa1c0d74902a21d32d3065997
Parents: d7fc7cf
Author: Ismael Juma <ismael@juma.me.uk>
Authored: Tue Feb 16 10:19:00 2016 -0500
Committer: Ewen Cheslack-Postava <me@ewencp.org>
Committed: Tue Feb 16 10:19:00 2016 -0500

----------------------------------------------------------------------
 build.gradle               |  6 +++---
 gradle/dependencies.gradle | 12 ++++++------
 2 files changed, 9 insertions(+), 9 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kafka/blob/f355918e/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index 27d88c7..275e250 100644
--- a/build.gradle
+++ b/build.gradle
@@ -22,8 +22,8 @@ buildscript {
   apply from: file('gradle/buildscript.gradle'), to: buildscript
 
   dependencies {
-    // For Apache Rat plugin to ignore non-Git files, need ancient version for Java 6 compatibility
-    classpath group: 'org.ajoberstar', name: 'grgit', version: '0.2.3'
+    // For Apache Rat plugin to ignore non-Git files
+    classpath "org.ajoberstar:grgit:1.5.0"
   }
 }
 
@@ -36,7 +36,7 @@ allprojects {
 }
 
 ext {
-  gradleVersion = "2.10"
+  gradleVersion = "2.11"
   buildVersionFileName = "kafka-version.properties"
 
   userMaxForks = project.hasProperty('maxParallelForks') ? maxParallelForks.toInteger() :
null

http://git-wip-us.apache.org/repos/asf/kafka/blob/f355918e/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/gradle/dependencies.gradle b/gradle/dependencies.gradle
index d0ce616..4053811 100644
--- a/gradle/dependencies.gradle
+++ b/gradle/dependencies.gradle
@@ -24,8 +24,8 @@ ext {
 
 versions += [
   argparse4j: "0.5.0",
-  bcpkix: "1.53",
-  hadoop: "2.7.1",
+  bcpkix: "1.54",
+  hadoop: "2.7.2",
   easymock: "3.4",
   jackson: "2.6.3",
   jetty: "9.2.14.v20151106",
@@ -34,13 +34,13 @@ versions += [
   junit: "4.12",
   lz4: "1.3.0",
   metrics: "2.2.0",
-  powermock: "1.6.3",
+  powermock: "1.6.4",
   reflections: "0.9.10",
   rocksDB: "3.10.1",
-  scalaTest: "2.2.5",
+  scalaTest: "2.2.6",
   scalaParserCombinators: "1.0.4",
-  slf4j: "1.7.6",
-  snappy: "1.1.2",
+  slf4j: "1.7.15",
+  snappy: "1.1.2.1",
   zkclient: "0.7",
   zookeeper: "3.4.6",
 ]


Mime
View raw message