juneau-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Bognar (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (JUNEAU-41) Prerequisites usage is deprecated for non maven-plugin projects
Date Thu, 13 Apr 2017 20:57:46 GMT

     [ https://issues.apache.org/jira/browse/JUNEAU-41?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James Bognar closed JUNEAU-41.
------------------------------
       Resolution: Fixed
    Fix Version/s:     (was: 6.1.0)
                   6.1.1

> Prerequisites usage is deprecated for non maven-plugin projects
> ---------------------------------------------------------------
>
>                 Key: JUNEAU-41
>                 URL: https://issues.apache.org/jira/browse/JUNEAU-41
>             Project: Juneau
>          Issue Type: Improvement
>          Components: Code
>    Affects Versions: 6.1.0
>            Reporter: Karl Heinz Marbaise
>            Priority: Minor
>             Fix For: 6.1.1
>
>         Attachments: 0001-JUNEAU-41-Prerequisites-usage-is-deprecated-for-non-.patch
>
>
> Currently the pom contains:
> {code:xml}
> <prerequisites>
>   <maven>3.2.0</maven>
> </prerequisites>
> {code}
> which is already defined deprecated for non maven-plugin project. This should be replaced
by using an [maven-enforcer-rule|http://maven.apache.org/enforcer/enforcer-rules/requireMavenVersion.html].
> See MNG-5297 and MNG-6092 for further reference and in the [Release notes for Maven 3.5.0|https://maven.apache.org/docs/3.5.0/release-notes.html].



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message