jmeter-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fschumac...@apache.org
Subject svn commit: r1771950 - /jmeter/trunk/build.xml
Date Tue, 29 Nov 2016 19:57:21 GMT
Author: fschumacher
Date: Tue Nov 29 19:57:21 2016
New Revision: 1771950

URL: http://svn.apache.org/viewvc?rev=1771950&view=rev
Log:
Require jdk 8+ for generating docs-api. Bugzilla Id: 60415

Modified:
    jmeter/trunk/build.xml

Modified: jmeter/trunk/build.xml
URL: http://svn.apache.org/viewvc/jmeter/trunk/build.xml?rev=1771950&r1=1771949&r2=1771950&view=diff
==============================================================================
--- jmeter/trunk/build.xml (original)
+++ jmeter/trunk/build.xml Tue Nov 29 19:57:21 2016
@@ -2261,9 +2261,9 @@ run JMeter unless all the JMeter jars ar
   </target>
 
   <target name="docs-api" description="Generate the API documentation.">
-    <available property="jdk1.7+" classname="java.lang.AutoCloseable"/>
-    <fail unless="jdk1.7+"
-          message="Must use Java 7 or later for creating the Javadocs"/>
+    <available property="jdk1.8+" classname="java.util.function.Consumer"/>
+    <fail unless="jdk1.8+"
+          message="Must use Java 8 or later for creating the Javadocs"/>
     <tstamp>
       <!-- Used to ensure end-year is up to date -->
       <format property="THISYEAR" pattern="yyyy"/>
@@ -2299,9 +2299,9 @@ run JMeter unless all the JMeter jars ar
       packagenames="org.apache.jmeter.*,org.apache.jorphan.*"
       excludepackagenames="org.apache.jorphan.timer">
       <classpath refid="classpath"/>
-      <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+      <link href="http://docs.oracle.com/javase/8/docs/api/"/>
     </javadoc>
-    <!-- No need for Javadoc patch (CVE-2013-1571) now we are using Java 7 minimum -->
+    <!-- No need for Javadoc patch (CVE-2013-1571) now we are using Java 8 minimum -->
   </target>
 
   <!--



Mime
View raw message