jmeter-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From milam...@apache.org
Subject svn commit: r1769490 - /jmeter/trunk/build.xml
Date Sun, 13 Nov 2016 12:22:45 GMT
Author: milamber
Date: Sun Nov 13 12:22:45 2016
New Revision: 1769490

URL: http://svn.apache.org/viewvc?rev=1769490&view=rev
Log:
Improve Ant version management. Currently we need at least Ant > 1.9.1
Bugzilla Id: 60364

Modified:
    jmeter/trunk/build.xml

Modified: jmeter/trunk/build.xml
URL: http://svn.apache.org/viewvc/jmeter/trunk/build.xml?rev=1769490&r1=1769489&r2=1769490&view=diff
==============================================================================
--- jmeter/trunk/build.xml (original)
+++ jmeter/trunk/build.xml Sun Nov 13 12:22:45 2016
@@ -84,6 +84,9 @@
 
   -->
 
+  <!-- Minimal version of Apache Ant requiere by this Ant script -->
+  <property name="ant.version.required" value="1.9.1" />
+
   <!-- Are we running under Gump? -->
   <property name="gump.run" value="false"/>
 
@@ -580,10 +583,21 @@
     <echo level="info">implementation.version = ${implementation.version}</echo>
   </target>
 
-  <target name="ant-version">
+  <target name="ant-version" depends="_check_ant-version">
 	    <echo level="info">ant.version = ${ant.version}</echo>
   </target>
 
+  <target name="_check_ant-version">
+    <antversion property="version.running" />
+    <fail message="FATAL ERROR:  The running Ant version, ${version.running}, is too old
for this task.">
+      <condition>
+        <not>
+          <antversion atleast="${ant.version.required}" />
+        </not>
+      </condition>
+    </fail>
+  </target>
+	
   <target name="init-docs" depends="report-anakia-missing">
     <echo level="info">eclipse.anakia = ${eclipse.anakia}</echo>
   </target>
@@ -3105,6 +3119,8 @@ run JMeter unless all the JMeter jars ar
   </target>
 
   <target name="_coverage.prepare" >
+     <available property="jacocoant.jar.available" file="${lib.coverage}/${jacocoant.jar}"/>
+     <fail message="This task requires JaCoCo library, please run download_jars target
to download it" unless="jacocoant.jar.available"/>
      <taskdef uri="antlib:org.jacoco.ant" resource="org/jacoco/ant/antlib.xml">
         <classpath path="${lib.coverage}/${jacocoant.jar}"/>
      </taskdef>
@@ -3170,7 +3186,7 @@ run JMeter unless all the JMeter jars ar
     </jacoco:report>
   </target>
 
-  <target name="coverage"  depends="_coverage.prepare, test-both, _allbatchtests, _coverage.report"/>
+  <target name="coverage"  depends="ant-version,_coverage.prepare, test-both, _allbatchtests,
_coverage.report"/>
 
   <target name="_check_exists" if="_check_exists">
     <fail message="Invalid call sequence - file.exists should not be defined" if="file.exists"/>



Mime
View raw message