jmeter-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pmoua...@apache.org
Subject svn commit: r1674486 - in /jmeter/trunk: src/core/org/apache/jmeter/engine/StandardJMeterEngine.java xdocs/changes.xml
Date Sat, 18 Apr 2015 12:02:17 GMT
Author: pmouawad
Date: Sat Apr 18 12:02:17 2015
New Revision: 1674486

URL: http://svn.apache.org/r1674486
Log:
Bug 57731 - TESTSTART.MS has always the value of the first Test started in Server mode in
NON GUI Distributed testing
Bugzilla Id: 57731

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java
    jmeter/trunk/xdocs/changes.xml

Modified: jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java
URL: http://svn.apache.org/viewvc/jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java?rev=1674486&r1=1674485&r2=1674486&view=diff
==============================================================================
--- jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java (original)
+++ jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java Sat Apr 18 12:02:17
2015
@@ -446,7 +446,7 @@ public class StandardJMeterEngine implem
         }
 
         notifyTestListenersOfEnd(testListeners);
-
+        JMeterContextService.endTest();
         if (JMeter.isNonGUI() && SYSTEM_EXIT_FORCED) {
             log.info("Forced JVM shutdown requested at end of test");
             System.exit(0);

Modified: jmeter/trunk/xdocs/changes.xml
URL: http://svn.apache.org/viewvc/jmeter/trunk/xdocs/changes.xml?rev=1674486&r1=1674485&r2=1674486&view=diff
==============================================================================
--- jmeter/trunk/xdocs/changes.xml (original)
+++ jmeter/trunk/xdocs/changes.xml Sat Apr 18 12:02:17 2015
@@ -150,6 +150,7 @@ Summary
     <li><bug>54826</bug>Don't fail on long strings in JSON responses when
displaying them as JSON in View Results Tree.</li>
     <li><bug>57734</bug>Maven transient dependencies are incorrect for
2.13</li>
     <li><bug>57821</bug>Command-line option "-X --remoteexit" doesn't work
since 2.13 (regression related to <bugzilla>57500</bugzilla>)</li>
+    <li><bug>57731</bug>TESTSTART.MS has always the value of the first
Test started in Server mode in NON GUI Distributed testing</li>
 </ul>
 
  <!--  =================== Thanks =================== -->



Mime
View raw message