incubator-ivy-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (IVY-478) build fails without emma code coverage JARs present
Date Tue, 08 May 2007 22:20:15 GMT

     [ https://issues.apache.org/jira/browse/IVY-478?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maarten Coene resolved IVY-478.
-------------------------------

    Resolution: Fixed

Should be ok now.
The instrumented classes are stored elsewhere

> build fails without emma code coverage JARs present
> ---------------------------------------------------
>
>                 Key: IVY-478
>                 URL: https://issues.apache.org/jira/browse/IVY-478
>             Project: Ivy
>          Issue Type: Bug
>         Environment: jdk 1.5
>            Reporter: Jeffrey Blatttman
>         Assigned To: Maarten Coene
>
> > BUILD FAILED
> > /Users/jtb/src/dependencies/init-ivy.xml:46: The following error occurred
> > while executing this line:
> > jar:file:/Users/jtb/.ivy/jars/ivy.jar!/fr/jayasoft/ivy/ant/antlib.xml:21:
> > taskdef A class needed by class org.apache.ivy.ant.IvyConfigure cannot be
> > found: com/vladium/emma/rt/RT
> OK, I think I know where the problem comes from. In our build when we use
> emma to instrument classes we instrument classes in place. Usually this is
> not a problem because the jar which is published is packaged before this
> intrumentation... but if you run a first build with instrumentation, and
> then run a second build without cleaning, the jar produced by the second
> build will contain instrumented classes, which of course are not meant to be
> actually used.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message