incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject Re: [VOTE] Pulsar Release 2.1.0-incubating Candidate 5
Date Tue, 31 Jul 2018 14:46:10 GMT
Hi,

Changing to +1 (binding) but please raise a JIRA and fix for next release.

> I had the same experience and response. See this email for the solution.
> 
> https://lists.apache.org/thread.html/0744146fe14b23753d3a7c9c08885a74a76b30a1885cb12bd49381c5@%3Cdev.pulsar.apache.org%3E

I tried  the -Dmaven.gitcommitid.skip=true option and was getting:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.7.0:compile
(default-compile) on project pulsar-common: Compilation failure: Compilation failure:
[ERROR] /Users/justinmclean/ApachePulsar/apache-pulsar-2.1.0-incubating/pulsar-common/src/main/java/org/apache/pulsar/common/api/proto/PulsarApi.java:[6727,56]
package org.apache.pulsar.shaded.com.google.protobuf.v241 does not exist seem you must 

But it seems you need to install rather than just compile, so looks like something is a little
broken here. Also the instructions in README.md say only "mvn install -DskipTests" so they
also need to be updated.

Thanks,
Justin



---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message