incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Merli <matteo.me...@gmail.com>
Subject Re: [VOTE] Pulsar Release 2.0.0-rc1-incubating Candidate 5
Date Sun, 27 May 2018 05:30:59 GMT
Hi Willem, I'm personally not familiar with BOM in Maven but we'll surely
take
a look. We just want to ensure that, out of the box, users won't have to
experience weird runtime errors, due when incompatible versions of some
library
required by different components.

We'll look into this and few other options to achieve that without
including twice
some of the dependencies in different forms.

Thank,
Matteo

On Sat, May 26, 2018 at 7:21 PM Willem Jiang <willem.jiang@gmail.com> wrote:

> My suggestion is using BOM the manage the third party dependencies which
> could save you some time to build a uber jar.
> It's not a blocker issue for the release, but it's a common practice to
> resolve the version conflicts of third party dependencies.
>
>
> Willem Jiang
>
> Twitter: willemjiang
> Weibo: 姜宁willem
>
> On Sat, May 26, 2018 at 8:22 AM, Sijie Guo <guosijie@gmail.com> wrote:
>
> > Thank you Willem. Comments inline
> >
> > On Fri, May 25, 2018 at 4:03 PM, Willem Jiang <willem.jiang@gmail.com>
> > wrote:
> >
> > > my +1.
> > >
> > > I checked:
> > >
> > > The sign and check sum for both src and binary distributions.
> > > The License and Notice file for src and binary distributions.
> > > I can build the binary from source.
> > >
> > > Here are some minor issues I found, it's not blocker issues please
> verify
> > > them and we can fix it in the next release.
> > >
> > > 1. It's a little big size for the binary ,  so I checked the files.
> > > It looks like there are java-instance.jar which holds all the jars in
> the
> > > lib directory. I think we need to find a way to avoid shipping the jars
> > > twice.
> > >
> >
> > java-instance.jar is a uber jar including all the dependencies for
> running
> > pulsar functions in process mode.
> >
> > it is needed for this release, because there are conflicts between
> > different protobuf/netty versions. so we have to do proper shading to
> > handle that.
> >
> > we are addressing that in master, the situation can be improved in 2.1
> > release.
> >
> >
> > >
> > > 2. There are three different version of Netty in the library,
> > > io.netty-netty-3.10.1.Final.jar
> > > io.netty-netty-all-4.1.21.Final.jar
> > > io.netty-netty-codec-http2-4.1.12.Final.jar
> > >
> > > as netty 3.x and netty4.x use different package name, we may need to go
> > > through all the netty 4.x dependencies.
> > >
> >
> > yeah. pulsar is using 4.1.21, however 3.10.1 and 4.1.12 are coming from
> its
> > transitive dependencies. hope that clarifies.
> >
> >
> > >
> > >
> > > Willem Jiang
> > >
> > > Twitter: willemjiang
> > > Weibo: 姜宁willem
> > >
> > > On Thu, May 24, 2018 at 1:21 PM, Matteo Merli <mmerli@apache.org>
> wrote:
> > >
> > > > This is the fifth release candidate for Apache Pulsar, version
> > > > 2.0.0-rc1-incubating.
> > > >
> > > > Pulsar is a highly scalable, low latency messaging platform running
> on
> > > > commodity hardware.
> > > > It provides simple pub-sub semantics over topics, guaranteed
> > > at-least-once
> > > > delivery of
> > > > messages, automatic cursor management for subscribers, and
> > > geo-replication.
> > > >
> > > > The only difference from previous candidate is a fix on the LICENSE
> > > > attached to bin distribution to correctly reflect all dependencies
> and
> > > > versions.
> > > >
> > > > Link to the voting thread on pulsar dev list:
> > > > https://lists.apache.org/thread.html/81359fe55cb75cd1621a70e9a5a0af
> > > > 02fb1a84549ab0046d335182fa@%3Cdev.pulsar.apache.org%3E
> > > >
> > > > It fixes the following issues:
> > > > https://github.com/apache/incubator-pulsar/milestone/12?closed=1
> > > >
> > > > *** Please download, test and vote on this release. This vote will
> stay
> > > > open
> > > > for at least 72 hours ***
> > > >
> > > > Note that we are voting upon the source (tag), binaries are provided
> > for
> > > > convenience.
> > > >
> > > > Source and binary files:
> > > > https://dist.apache.org/repos/dist/dev/incubator/pulsar/
> > > > pulsar-2.0.0-rc1-incubating-candidate-5/
> > > >
> > > > SHA-1 checksums:
> > > > 72ee624c9b1485cc4c12b71e3807c7c05ec900ad
> > > > apache-pulsar-2.0.0-rc1-incubating-bin.tar.gz
> > > > c525457db8f9c4ea859c595c93e9207631cda19f
> > > > apache-pulsar-2.0.0-rc1-incubating-src.tar.gz
> > > >
> > > > Maven staging repo:
> > > > https://repository.apache.org/content/repositories/
> > orgapachepulsar-1017/
> > > >
> > > > The tag to be voted upon:
> > > > v2.0.0-rc1-incubating-candidate-5 (08708a198606fb934e46f6cb0b614f
> > > > 2babf613e4)
> > > > https://github.com/apache/incubator-pulsar/releases/tag/
> > > > v2.0.0-rc1-incubating-candidate-5
> > > >
> > > > Pulsar's KEYS file containing PGP keys we use to sign the release:
> > > > https://dist.apache.org/repos/dist/release/incubator/pulsar/KEYS
> > > >
> > > > Please download the the source package, and follow the README to
> build
> > > > and run the Pulsar standalone service.
> > > >
> > > >
> > > > --
> > > > Matteo Merli
> > > > <mmerli@apache.org>
> > > >
> > >
> >
>
-- 
Matteo Merli
<mmerli@apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message