groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Di Tommaso <paolo.ditomm...@gmail.com>
Subject Re: Groovy 3.0.0-beta3 and Spock
Date Thu, 08 Aug 2019 06:53:25 GMT
Yes, fix solves the compilation error, tho now I got a bunch of failing
tests, tho it looks more related to a Spock problem.

Thanks!

On Thu, Aug 8, 2019 at 12:37 AM Marcin ZajÄ…czkowski <mszpak@wp.pl> wrote:

> On 2019-08-07 20:33, Paolo Di Tommaso wrote:
> > Team, congrats for a new build toward Groovy 3.0
> >
> > I've was giving it a try and I'm getting this compilation error related
> to
> > Spock:
> >
> > startup failed:
> > Could not instantiate global transform class
> > org.spockframework.compiler.SpockTransform specified at
> >
> jar:file:/Users/pditommaso/.gradle/caches/modules-2/files-2.1/org.spockframework/spock-core/1.3-groovy-2.5/6f0df2cf4549dcc4b914971675da7e224e893e82/spock-core-1.3-groovy-2.5.jar!/META-INF/services/org.codehaus.groovy.transform.ASTTransformation
> >  because of exception java.lang.reflect.InvocationTargetException
> >
> >
> >  May a new version of Spock is expected to be used with Groovy 3?
>
> Hi. You may want to checked with the snapshot version of Spock as
> described in that issue:
> https://github.com/spockframework/spock/issues/997 and report the
> potential problems there.
>
> Marcin
>
> --
> https://blog.solidsoft.info/ - Working code is not enough
>

Mime
View raw message