groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Hiller <dhil...@twitter.com>
Subject trying to understand groovy's support for jdk9
Date Mon, 01 Jul 2019 15:52:42 GMT
I ran into the issue that slfj4j 2.0 + logback 1.3 is no longer supporting
the groovy stuff due to issues on the publishing of groovy jars or
something.  I opened this ticket on logback
https://jira.qos.ch/browse/LOGBACK-1474

I am now trying to either open a ticket on groovy or figure out what is the
issue.  I read this

https://markmail.org/thread/nekeppbvwrfl7hbb#query:+page:1+mid:obdyvuv24kqpxm6v+state:results
and
https://stackoverflow.com/questions/50163197/groovy-java-9-modules-support
(which seems very non-ideal and a huge amount of hacking to get it working)

I then don't see any tickets for groovy to support consumers of groovy jars
in jdk 9 either when I do a search

https://issues.apache.org/jira/browse/GROOVY-8338?jql=project%20%3D%20GROOVY%20AND%20text%20~%20%22jdk%209%22

This project would also LOVE to start using jdk 9 modules and would like to
continue to use groovy github.com/deanhiller/webpieces

Should I open a jira ticket? or is there one that I could not find?

thanks,
Dean

Mime
View raw message