groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Leblanc <sean.lebl...@icd-tech.com>
Subject Re: Code coverage tools?
Date Fri, 21 Jun 2019 15:44:46 GMT
What does the forcedModules do?


From: "Corum, Michael" <mcorum@rgare.com>
Reply-To: "users@groovy.apache.org" <users@groovy.apache.org>
Date: Friday, June 21, 2019 at 5:43 AM
To: "users@groovy.apache.org" <users@groovy.apache.org>, Scott Hickey <jscotthickey@gmail.com>
Subject: Re: Code coverage tools?

Actually in my case, @CompileStatic helped improve accuracy of coverage for Cobertura.  For
Groovy/Dropwizard, I using this in my build.gradle:

Plugins {
         id "net.saliman.cobertura" version "2.5.4"
}

And then later in my build.gradle, I also include:


configurations.all {
    resolutionStrategy {
        forcedModules = ['org.ow2.asm:asm:5.0.3', 'org.ow2.asm:asm-tree:5.0.3', 'org.ow2.asm:asm-commons:5.0.3',
'org.ow2.asm:asm-util:5.0.3', 'org.ow2.asm:asm-analysis:5.0.3']
    }
}

I probably need to update the versions on those but that helped the accuracy for Cobertura
quite a bit.

Michael Corum
VP, Technical Architecture Solutions

RGA Reinsurance Company
16600 Swingley Ridge Road
Chesterfield, Missouri 6301701706
T 636.736.7066
www.rgare.com


From: Søren Berg Glasius <soeren@glasius.dk>
Reply-To: "users@groovy.apache.org" <users@groovy.apache.org>
Date: Friday, June 21, 2019 at 1:04 AM
To: "users@groovy.apache.org" <users@groovy.apache.org>, Scott Hickey <jscotthickey@gmail.com>
Subject: Re: Code coverage tools?

External e-mail. Use caution! / Courriel externe. Faites attention!
________________________________
@Scott Hickey<mailto:jscotthickey@gmail.com> but can you make it work with @CompileStatic
and the Elvis operator? We are having big struggles to get that working. (In a Grails 3.3.x
application)
Best regards / Med venlig hilsen,
Søren Berg Glasius

Hedevej 1, Gl. Rye, 8680 Ry, Denmark
Mobile: +45 40 44 91 88, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.


On Fri, 21 Jun 2019 at 00:31, Scott Hickey <jscotthickey@gmail.com<mailto:jscotthickey@gmail.com>>
wrote:
We are using Clover - it is open source now. We have found it works much better for us at
Mutual of Omaha than JaCoCo or Cobertura.

Scott Hickey
Mutual of Omaha

On Thu, Jun 20, 2019 at 12:02 PM Sean LeBlanc <sean.leblanc@icd-tech.com<mailto:sean.leblanc@icd-tech.com>>
wrote:
What are people using currently to get accurate code coverage from new(ish) versions of Groovy?
We are on 2.4.10 and I see similar issues as what this thread is talking about:

https://github.com/cobertura/cobertura/issues/184<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_cobertura_cobertura_issues_184&d=DwMFaQ&c=5uPv0lijNz76uSeaN5P0Zw&r=rh3Qrw7azSI9xkZZ-a8EEw&m=p4nbyKOuvpOHHXv6u3ddQHdcrJqAeyq5xSfJhWp1BOc&s=VyqZbdEQzSqkh0b0fC9LKCqP6likq_eHkVjwWCHpmws&e=>



Does anyone have good experiences with getting more accurate code coverage numbers with Groovy
> 2.0.8? And what route did you take?
** EXTERNAL **
________________________________
Mime
View raw message